hdu 3117 Fibonacci Numbers 斐波那契数列前四位求法

The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.

What is the numerical value of the nth Fibonacci number?
 

Input
For each test case, a line will contain an integer i between 0 and 10 8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”). 

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
 

Sample Input
  
  
0 1 2 3 4 5 35 36 37 38 39 40 64 65
 

Sample Output
  
  
0 1 1 2 3 5 9227465 14930352 24157817 39088169 63245986 1023...4155 1061...7723 1716...7565


求后四位好求 但前四位不是很好求 我也是看了大佬的博客学的,附上博客地址     http://blog.csdn.net/xiangaccepted/article/details/74131404

首先如果我们要求 n^k的前四位应该怎么办 设  n^k=10^p     p=lg n^k =k*lg n     

x=(int)p   y=p-x   那么  n^k =10^x +10 ^y      

10^x 代表 有x 个0    10^y是它的小数部分  

计算方法:

 double  p=k*log(n);

p=p-(int)p;

int ans=(int)(pow(10,p)*1000);

那么 转换为矩阵 我们只要在矩阵里面存p的值就行了;

原来的  初始矩阵      系数矩阵     (初始矩阵从 斐波那契 -1   -2  项开始)

              0  1                 1  1 

              0  0                 1  0 

不过 没有p 使得值为0 那么我们存-1 后来特判就行 

初始矩阵(double)      系数矩阵(double)

-1  0                             0  0     (0表示1及10^0)  (若是2的话就表示100及10^2

-1  -1                            0  -1    (-1表示原来的数字是0,遇到-1则特判即可)

我们矩阵的乘法也得改变

原本  100*100=10000   -> 2+2=4

         10^5.5+10^3.6=10^3.6  *  (10^1.9+1)   ->   5.5+3.6=3.6+log ( pow( 10 , 1.9 ) + 1 )

#include<stdio.h>

#include<stdlib.h>

#include<string.h>

#include<algorithm>
#include<map>
#include<queue>
#include<math.h>
#include<vector>
#include<iostream>
using namespace std;
typedef long long ll;
const int mod=10000;
int n;
int f[100];
struct node1//求前4位
{
    int n;
    double a[2][2];
    node1()
    {
        memset(a,0,sizeof(a));
    }
}A,B;
node1 operator *(node1 a,node1 b)
{
    node1 ans;
    ans.n=a.n;
    for(int i=0;i<a.n;i++)
        for(int j=0;j<2;j++)
        {
           double ma,mb;
           int flag1=0,flag2=0;
           if(a.a[i][0]<0||b.a[0][j]<0) flag1=1;
           else ma=a.a[i][0]+b.a[0][j];
           if(a.a[i][1]<0||b.a[1][j]<0) flag2=1;
              else mb=a.a[i][1]+b.a[1][j];
           if(flag1&&flag2) ans.a[i][j]=-1.0;
           else if(flag1&&!flag2)  ans.a[i][j]=mb;
           else if(!flag1&&flag2) ans.a[i][j]=ma;
           else
           {
               double mc;
               if(mb>ma) swap(mb,ma);
               mc=mb; ma-=mb;mb=0.0;
               ans.a[i][j]=mc+log10(1+pow(10,ma));
           }
        }
          return ans;
}
void aa1(int x)
{
    node1 ans=A,p=B;
    while(x)
    {
        if(x&1)
            ans=ans*p;
        p=p*p;
        x=x/2;
    }
    double l=ans.a[0][0];
    l=l-(int)l;
    l=pow(10,l);
    printf("%d...",(int)(l*1000));
}
struct node2//求后四位
{
    int n;
    int  a[2][2];
    node2()
    {
        memset(a,0,sizeof(a));
    }
}A2,B2;
node2 operator *(node2 a,node2 b)
{
    node2 ans;
    ans.n=a.n;
    for(int i=0;i<a.n;i++)
        for(int j=0;j<2;j++)
          for(int k=0;k<2;k++)
    ans.a[i][j]=((ans.a[i][j]+a.a[i][k]*b.a[k][j])%mod+mod)%mod;
    return ans;
}
void aa2(int x)
{
    node2 ans=A2,p=B2;
    while(x)
    {
        if(x&1)
           ans=ans*p;
         p=p*p;
         x=x/2;
    }
    int o=(ans.a[0][0]%mod+mod)%mod;
    printf("%04d\n",o);
}
int main()
{
   A.a[0][0]=-1,A.a[0][1]=0;
   B.a[0][0]=0,B.a[0][1]=0;
   B.a[1][0]=0,B.a[1][1]=-1;
   A.n=1,B.n=2;
   A2.a[0][0]=0,A2.a[0][1]=1;
   B2.a[0][0]=1,B2.a[0][1]=1;
   B2.a[1][0]=1,B2.a[1][1]=0;
   A2.n=1,B2.n=2;
   f[0]=0;
   f[1]=1;
   for(int i=2;i<=40;i++)
    f[i]=f[i-1]+f[i-2];
   while(~scanf("%d",&n))
   {
  if(n<40)
    printf("%d\n",f[n]);
  else
  {
     aa1(n);
     aa2(n);
  }
   }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值