POJ 2356 Find a multiple (在n个数组成的数列中找出若干个连续数使它们之和能被n整除)

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).
Input
The first line of the input contains the single number N. Each of next N lines contains one number from the given set.
Output
In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.
Sample Input
5
1
2
3
4
1
Sample Output
2
2
3

题意 :从n个数找出一些数,他们的和能被n整除

解 :能被整除即sum%n==0 

那么 设ans[i]为从1到i的和 那么总共有n个ans,他们都mod  n

第一种情况    有一个ans[i]%n==0  那么答案就是从 1到i

第二种情况    没有ans[i]%n==0的  那么肯定会有两个的余是相同的 ans[i]%n == ans[j]%n  (因为余值从0到n-1 ,而有n个余值) ,答案就是从 i+1 到  j  

 

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<stack>
#include<vector>
#include<queue>
#include<map>
#define nn 500
#define mm 100001
#define inff 0x3fffffff
using namespace std;
#pragma comment(linker, "/STACK:102400000,102400000")
int n;
long long sum;
int a[10011];
int v[10011];
int st,ed,oo;
int main()
{
   while(~scanf("%d",&n))
   {
       sum=0;
       oo=0;
       memset(v,0,sizeof(v));
       for(int i=1;i<=n;i++)
       {
           scanf("%d",&a[i]);
           if(oo)
            continue;
           sum+=a[i];
           if(sum%n==0)
           {
               st=1;
               ed=i;
               oo=1;
             continue;
           }
           if(!v[sum%n])
               v[sum%n]=i;
           else
           {
               st=v[sum%n]+1;
               ed=i;
               oo=1;
           }
       }
       printf("%d\n",ed-st+1);
       for(int i=st;i<=ed;i++)
        printf("%d\n",a[i]);
   }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值