A1102. Invert a Binary Tree (25)

题目描述

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
题意解析
题目其实很简单,就是按照样例的输入,构建一颗二叉树,然后依次层次遍历和中序遍历。
解题思路
采用链表存储二叉树,便于层次遍历和中序遍历,关键是根据输入创建一颗二叉树。首先遍历输入,找出根节点(节点编号从0~N,没有出现的就是根节点)。先创建根节点并入队,然后遍历队列,当当前节点有左子树时就创建并入队,有右子数亦然,队列为空时,二叉树就创建好了。最后,按照要求遍历即可。
参考代码
<span style="font-size:14px;">#include <cstdio>
#include <queue>
#include <malloc.h>

using namespace std;

const int maxn = 20;

int n;
bool flag[maxn] = {false};

struct N
{
	char l;
	char r;
}temp[maxn];

struct node
{
	int data;
	struct node * lchild;
	struct node * rchild;
};

queue<node *> q;

node * createTree(int head)
{
	node * root = (node *)malloc(sizeof(node));
	root->data = head;
	root->lchild = NULL;
	root->rchild = NULL;
	q.push(root);
	while(!q.empty())
	{
		node * nroot = q.front();
		int i = nroot->data;
		q.pop();
		if(temp[i].l != '-')
		{
			int l = temp[i].l - '0';
			node * n = (node *)malloc(sizeof(node));
			n->data = l;
			n->lchild = NULL;
			n->rchild = NULL;
			nroot->lchild = n;
			q.push(n);
		}
		if(temp[i].r != '-')
		{
			int r = temp[i].r - '0';
			node * n = (node *)malloc(sizeof(node));
			n->data = r;
			n->lchild = NULL;
			n->rchild = NULL;
			nroot->rchild = n;
			q.push(n);
		}
	}
	return root;
}

queue<node *> order_q;

void level_order(node * root)
{
	order_q.push(root);
	int i = 0;
	while(!order_q.empty())
	{
		node * n = order_q.front();
		order_q.pop();
		if(i == 0)
			printf("%d",n->data);
		else
			printf(" %d",n->data);
		i++;
		if(n->rchild != NULL)
			order_q.push(n->rchild);
		if(n->lchild != NULL)
			order_q.push(n->lchild);
	}
}

int x = 0;
void in_order(node * root)
{
	if(root->rchild != NULL)
		in_order(root->rchild);
	if(x == 0)
	{
		printf("%d",root->data);
		x++;
	}
	else
	{
		printf(" %d",root->data);
	}
	if(root->lchild != NULL)
		in_order(root->lchild);
}

int main()
{
	node * root;
	int head;
	scanf("%d",&n);
	getchar();
	for(int i=0;i<n;i++)
	{
		scanf("%c %c",&temp[i].l,&temp[i].r);
		getchar();
	}
	for(int i=0;i<n;i++)
	{
		if(temp[i].l != '-')
			flag[temp[i].l-'0'] = true;
		if(temp[i].r != '-')
			flag[temp[i].r-'0'] = true;
	}
	for(int i=0;i<n;i++)
	{
		if(flag[i] == false)
		{
			head = i;
			break;
		}
	}
	root = createTree(head);
	level_order(root);
	printf("\n");
	in_order(root);
	return 0;
}</span>



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值