A1110. Complete Binary Tree (25)

题目描述

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:
NO 1

参考代码

#include <cstdio>
#include <queue>
#include <malloc.h>
#include <vector>
#include <string.h>

using namespace std;

const int maxn = 30;

int n;

bool vis[maxn] = {false};

struct tt
{
	char l[3];
	char r[3];
	int l_int;
	int r_int;
}number[maxn];

struct Node
{
	int data;			
	Node * lchild;
	Node * rchild;
};

Node * result;

Node * createTree(int k)
{
	queue<Node *> q;
	Node * root = (Node *)malloc(sizeof(Node));
	root->data = k;
	root->lchild = NULL;
	root->rchild = NULL;
	q.push(root);
	while(!q.empty())
	{
		Node * node = q.front();
		int node_index = node->data;
		q.pop();
		if(strcmp(number[node_index].l,"-") != 0)
		{
			Node * lch = (Node *)malloc(sizeof(Node));
			lch->data = number[node_index].l_int;
			lch->lchild = NULL;
			lch->rchild = NULL;
			node->lchild = lch;
			q.push(lch);
		}
		if(strcmp(number[node_index].r,"-") != 0)
		{
			Node * rch = (Node *)malloc(sizeof(Node));
			rch->data = number[node_index].r_int;
			rch->lchild = NULL;
			rch->rchild = NULL;
			node->rchild = rch;
			q.push(rch);
		}
	}
	return root;
}
vector<Node *> v; 
bool isCompleteBinaryTree(Node * root)
{
	queue<Node *> q;
	v.push_back(root);
	q.push(root);
	while(!q.empty())
	{
		Node * node = q.front();
		q.pop();
		v.push_back(node->lchild);
		v.push_back(node->rchild);
		if(node->lchild != NULL)
		q.push(node->lchild);
		if(node->rchild != NULL)
		q.push(node->rchild);
	}
	int count = 0;
	for(int i=0;i<v.size();i++)
	{
		if(v[i] != NULL)
		{
			count++;
			result = v[i];
		}
		else
		{
			if(count == n)
			{
			return true;
			}
			else
			{
				return false;
			}
		}
	}
}

int main()
{
	int k;
	Node * root;
	scanf("%d",&n);
	getchar();
	for(int i=0;i<n;i++)
	{
		scanf("%s %s",number[i].l,number[i].r);
		getchar();
	}
	for(int i=0;i<n;i++)
	{
		if(strcmp(number[i].l,"-") != 0)
		{
			int result = 0;
			for(int j=0;j<strlen(number[i].l);j++)
			{
				result = result * 10 + number[i].l[j] - '0';
			}
			number[i].l_int = result;
			vis[number[i].l_int] = true;
		}
		if(strcmp(number[i].r,"-") != 0)
		{
			int result = 0;
			for(int j=0;j<strlen(number[i].r);j++)
			{
				result = result * 10 + number[i].r[j] - '0';
			}
			number[i].r_int = result;
			vis[number[i].r_int] = true;
		}
	}
	for(int i=0;i<n;i++)
	{
		if(vis[i] == false)
		{
			k = i;
			break;
		}
	}
	root = createTree(k);
	if(isCompleteBinaryTree(root))
	{
		printf("YES %d\n",result->data);
	}
	else
	{
		printf("NO %d\n",root->data);
	}
	return 0;
}


下面是用C语言实现的代码,判断一棵二叉树是否为完全二叉树。 ```c #include <stdio.h> #include <stdlib.h> #include <stdbool.h> typedef struct TreeNode { int val; struct TreeNode *left; struct TreeNode *right; } TreeNode; typedef struct Queue { TreeNode **data; int front; int rear; int size; } Queue; Queue *createQueue(int size) { Queue *q = (Queue *)malloc(sizeof(Queue)); q->data = (TreeNode **)malloc(sizeof(TreeNode *) * size); q->front = q->rear = 0; q->size = size; return q; } bool isEmpty(Queue *q) { return q->front == q->rear; } bool isFull(Queue *q) { return (q->rear + 1) % q->size == q->front; } void enqueue(Queue *q, TreeNode *node) { if (isFull(q)) { return; } q->data[q->rear] = node; q->rear = (q->rear + 1) % q->size; } TreeNode *dequeue(Queue *q) { if (isEmpty(q)) { return NULL; } TreeNode *node = q->data[q->front]; q->front = (q->front + 1) % q->size; return node; } bool isCompleteTree(TreeNode* root) { if (root == NULL) { return true; } Queue *q = createQueue(1000); bool flag = false; enqueue(q, root); while (!isEmpty(q)) { TreeNode *node = dequeue(q); if (node->left) { if (flag) { return false; } enqueue(q, node->left); } else { flag = true; } if (node->right) { if (flag) { return false; } enqueue(q, node->right); } else { flag = true; } } return true; } int main() { TreeNode *root = (TreeNode *)malloc(sizeof(TreeNode)); root->val = 1; root->left = (TreeNode *)malloc(sizeof(TreeNode)); root->left->val = 2; root->right = (TreeNode *)malloc(sizeof(TreeNode)); root->right->val = 3; root->left->left = (TreeNode *)malloc(sizeof(TreeNode)); root->left->left->val = 4; root->left->right = (TreeNode *)malloc(sizeof(TreeNode)); root->left->right->val = 5; root->right->left = (TreeNode *)malloc(sizeof(TreeNode)); root->right->left->val = 6; printf("%s\n", isCompleteTree(root) ? "true" : "false"); return 0; } ``` 代码中使用了队列来存储二叉树中的节点,判断是否为完全二叉树的方法是,从根节点开始,每层的节点必须都存在,否则后面的节点都必须是叶子节点才满足完全二叉树的定义。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值