A1112. Stucked Keyboard (20)

题目描述

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string "thiiis iiisss a teeeeeest" we know that the keys "i" and "e" might be stucked, but "s" is not even though it appears repeatedly sometimes. The original string could be "this isss a teest".

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k ( 1<k<=100 ) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and "_". It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:
3
caseee1__thiiis_iiisss_a_teeeeeest
Sample Output:
ei
case1__this_isss_a_teest

解题说明

注意点:当k=2时,aasaaa中的a不是stucked key。

参考代码

#include <cstdio>
#include <string.h>

const int maxn = 1000100;

int k,l;
char str[maxn];
int temp[maxn] = {-1},temp1[maxn];
int count1[maxn] = {0};

int main()
{
	int i;
	for(i =0;i<maxn;i++)
		temp[i] = -1;
	scanf("%d",&k);
	getchar();
	gets(str);
	l = strlen(str);
	count1[str[0]]++;
	for(i = 1;i<l;i++)
	{
		if(str[i] == str[i-1])
		{
			count1[str[i]]++;	
		}
		else
		{
			if(count1[str[i-1]] >= k)
			{
				if(temp[str[i-1]] == -1)
				{
                    if(count1[str[i-1]] % k == 0)
                   {
                        temp[str[i-1]] = 1;
                    }
                    else
                    {
                        temp[str[i-1]] = 0;
                    }
                }
				else if(temp[str[i-1]] == 0)
					temp[str[i-1]] = 0;
				 else if(temp[str[i-1]] == 1)
                {
                    if(count1[str[i-1]] % k == 0)
                    {
                        temp[str[i-1]] = 1;
                    }
                    else
                    {
                        temp[str[i-1]] = 0;
                    }

                }
			}
			else
			{
				temp[str[i-1]] = 0;
				count1[str[i-1]] = 0;
			}

			if(temp[str[i]] == 0)
				continue;
			else if(temp[str[i]] == -1)
			{
				count1[str[i]] = 0;
				count1[str[i]]++;
			}
			else
			{
				count1[str[i]] = 0;
				count1[str[i]]++;
			}
		}
	}
	if(temp[str[i-1]] == -1)
    {
        if(count1[str[i-1]] >= k)
        {
            if(count1[str[i-1]] % k == 0)
            {
                 temp[str[i-1]] = 1;
            }
            else
            {
                temp[str[i-1]] = 0;
            }
        }
        else
        {
            temp[str[i-1]] = 0;
        }
    }
    else if(temp[str[i-1]] == 1)
    {
        if(count1[str[i-1]] < k)
            temp[str[i-1]] = 0;
        if(count1[str[i-1]] >= k)
        {
            if(count1[str[i-1]] % k == 0)
            {
                temp[str[i-1]] = 1;
            }
            else
            {
                temp[str[i-1]] = 0;
            }
        }

    }
	for(int i=0;i<l;i++)
	{
		temp1[str[i]] = temp[str[i]];
	}
	for(int i=0;i<l;i++)
	{
		if(temp1[str[i]] == 1)
		{
			printf("%c",str[i]);
			temp1[str[i]] = 0;
		}
	}
	printf("\n");
	for(int i=0;i<l;i++)
	{
		if(temp[str[i]] == 0)
			printf("%c",str[i]);
		else if(temp[str[i]] == 1)
		{
			printf("%c",str[i]);
			i = i + k - 1;
		}
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值