Dinner(南阳oj218)(水题,主要是测试数据太弱了)

Dinner

时间限制: 100 ms  |  内存限制: 65535 KB
难度: 1
描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl
提示

The tableware only contains: bowl, knife, fork and chopsticks.


这道题测试数据在nyoj系统上面实在是太弱了。  输入重复的餐具输出重复餐具或者是输出不重名餐具都是可以AC的,我真的服,因为这完全是两种不同的情况



当输入重复的的餐具名输入重复重复名时代码:

#include<stdio.h>
#include<string.h>
int main()
{
	char s[1000][20];
	int i,n;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
		    scanf("%s",s[i]);
		int num=0;
		for(i=0;i<n;i++)
		{
			if((strcmp(s[i],"bowl")==0))
			{
				num++;
				if(num==1)
				   printf("bowl");
				else
				   printf(" bowl");
			}
			if((strcmp(s[i],"knife")==0))
			{
				num++;
				if(num==1)
				   printf("knife");
				else
				   printf(" knife");
		    }
		    if((strcmp(s[i],"fork")==0))
		    {
		    	num++;
		    	if(num==1)
		    	   printf("fork");
		    	else
		    	   printf(" fork");
			}
			if((strcmp(s[i],"chopsticks")==0))
			{
				num++;
				if(num==1)
				   printf("chopsticks");
				else
				   printf(" chopsticks");
			}
		}
		printf("\n");
	}
}


当输入重复餐具,但是输出唯一餐具时代码:


#include<stdio.h>
#include<string.h>
int main()
{
	char s[1000][20];
	int i,n;
	int vis[4];
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
		    scanf("%s",s[i]);
		int num=0;
		memset(vis,0,sizeof(vis));
		for(i=0;i<n;i++)
		{
			if(!vis[0]&&(strcmp(s[i],"bowl")==0))
			{
				vis[0]=1;
				num++;
				if(num==1)
				   printf("bowl");
				else
				   printf(" bowl");
			}
			if(!vis[1]&&(strcmp(s[i],"knife")==0))
			{
				vis[1]=1;
				num++;
				if(num==1)
				   printf("knife");
				else
				   printf(" knife");
		    }
		    if(!vis[2]&&(strcmp(s[i],"fork")==0))
		    {
		    	vis[2]=1;
		    	num++;
		    	if(num==1)
		    	   printf("fork");
		    	else
		    	   printf(" fork");
			}
			if(!vis[3]&&(strcmp(s[i],"chopsticks")==0))
			{
				vis[3]=1;
				num++;
				if(num==1)
				   printf("chopsticks");
				else
				   printf(" chopsticks");
			}
		}
		printf("\n");
	}
}

### 回答1: 一本通 OJ 题库的测试数据,通常是用来验证提交的代码在各种情况下的正确性。测试数据可以分为两种类型,手动和自动。 手动测试数据是由题目的出题人根据题意和数据范围设计的一组数据,用来检测程序的正确性和运行效率。手动测试数据的优点是能够涵盖各种情况,但缺点是数量相对较少,不足以覆盖所有可能的情况。 自动测试数据是由程序自动生成的一组数据,可以生成大量的数据以检测程序的健壮性和效率。自动测试数据的优点是数量大且可以自动生成,但缺点是可能无法覆盖某些特殊情况,导致漏洞。 对于提交的代码,一本通 OJ 题库会对其进行编译和运行,然后与测试数据进行比较,判断代码的正确性和效率。如果代码通过了测试数据,就会被判定为正确,否则会被判定为错误,并给出具体的错误信息,供用户进行调试和改进。 综上所述,一本通 OJ 题库的测试数据是一个重要的组成部分,它可以帮助用户测试代码的正确性和运行效率,提高用户的编程技能,同时也可以帮助出题人设计更好的题目,并保证题目的质量和难度。 ### 回答2: 一本通 oj题库是一个在线的程序设计竞赛平台,提供了丰富的编程题目和测试数据测试数据是用于对程序进行测评的输入和输出数据集合。在题目描述中,会对问题进行详细的解释和要求,并提供多组测试数据作为样例,让程序员运行他们的代码,并得到程序的输出结果。 测试数据通常包括正向测试数据和反向测试数据。正向测试数据是指符合题目条件的测试数据,覆盖了大多数情况,测试程序是否正确;而反向测试数据则是用于测试程序是否能够正确处理异常情况。 在使用一本通 oj题库时,程序员不仅需要通过编写算法和程序的方式解决问题,还需要通过分析测试数据来判断自己的代码是否正确。而一本通 oj题库的丰富数据集合为程序员提供了充足的测试数据,帮助程序员准确地检测代码中存在的漏洞和错误。 总之,一本通 oj题库提供了全面的测试数据来测试程序员的代码是否满足题目描述和要求,是程序员进行程序设计竞赛、算法练习和编程学习的良好平台。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值