POJ 1131 Octal Fractions (Java大数,八进制转十进制)

Octal Fractions
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6959 Accepted: 3825

Description

Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.953125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point. 

Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals.

Input

The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k.

Output

Your output will consist of a sequence of lines of the form 

0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]


where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.

Sample Input

0.75
0.0001
0.01234567

Sample Output

0.75 [8] = 0.953125 [10]
0.0001 [8] = 0.000244140625 [10]
0.01234567 [8] = 0.020408093929290771484375 [10]

Source



题意:输入一个8进制的小于0的数,将其转换为10进制.

PS:原先在API中找输入为8进制的方法,但是没有找到!!网上看了别人的代码,确实没有!都用模拟,但比C/C++好多了
转换方式:
例如:
0.75[8]---->7*8^(-1) + 5*8^(-2)=0.953125 [10]

AC代码:

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while (sc.hasNext()) {
			String str = sc.next();
			BigDecimal ans = new BigDecimal(0);
			BigDecimal base = new BigDecimal(1);
			int length = str.length();
			for (int i = 2; i < length; i++) {
				base = base.divide(new BigDecimal(8));
				BigDecimal t = new BigDecimal(str.charAt(i)-'0');
				ans = ans.add(t.multiply(base));
			}
			System.out.println(str+" [8] = "+ans+" [10]");
		}
	}

}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值