【POJ 1837】Balance(01背包)

Description

Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights’ values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4
-2 3
3 4 5 8

Sample Output

2

题目大意

有一个天平,C个位置上有钩子,有G个砝码,要求用上所有砝码,问有几种方案可以使天平平衡

思路

先要做一个坐标轴平移。dp[i][j]表示放置i个砝码,j状态的时候有多少方案数。我把坐标轴平移了10000.所以最后输出的答案就是dp[G][10000]。中间枚举的时候,只有dp[i-1][j]这个状态存在方案的时候才枚举一遍K

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=20000;

int dp[25][maxn],c,g,w[25],pos[25];

int main()
{
    while(~scanf("%d %d",&c,&g))
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=c;i++)
            scanf("%d",&pos[i]);
        for(int i=1;i<=g;i++)
            scanf("%d",&w[i]);
        dp[0][10000]=1;
        for(int i=1;i<=g;i++)
        {
            for(int j=0;j<20000;j++)
            {
                if(dp[i-1][j])
                {
                    for(int k=1;k<=c;k++)
                    {
                        dp[i][j+w[i]*pos[k]]+=dp[i-1][j];
                    }
                }
            }
        }
        printf("%d\n",dp[g][10000]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值