HDU-3853 LOOPS (概率DP)

77 篇文章 0 订阅

LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)


Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




 

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


 

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 

Sample Input
  
  
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output
  
  
6.000

题目大意:给定一个举行迷宫,初始在(1,1),在每一点(i,j)分别有三个概率p1,p2,p3分别传送至(i,j),(i,j+1),(i+1,j),每次传送消耗两点魔力值,求到达(r,c)时消耗魔力的期望?

设dp[i][j]表示从(i,j)开始到达目标状态时消耗魔力的期望,则dp[r][c]=0;

状态转移方程为:dp[i][j]=p1*(dp[i][j]+2)+p2*(dp[i][j+1]+2)+p3*(dp[i+1][j]+2);

解得:dp[i][j]=(p2*dp[i][j+1]+p3*dp[i+1][j]+2)/(1-p1);

写的时候觉得不能写成“人人为我”型,导致有个常数,时间较长,其实直接从(r,c)开始枚举即可。。。(但是时间并没有快多少)

【注意】如果非(r,c)点,p1为1时,则不会进入该点,因为题目保证最终结果不超过1000000(应该是通过其它点控制不能进入该点),这个太坑了,完全想不到。。。

#include <cstdio>
#include <cmath>
#include <algorithm>

using namespace std;
const int MAXN=1005;

int r,c;
double dp[MAXN][MAXN];
double p[MAXN][MAXN][3];

int main() {
    while(scanf("%d%d",&r,&c)==2) {
        for(int i=1;i<=r;++i) {
            for(int j=1;j<=c;++j) {
                scanf("%lf%lf%lf",&p[i][j][0],&p[i][j][1],&p[i][j][2]);
                dp[i][j]=2;
            }
        }
        dp[r][c]=0;
        p[r][c][0]=0;
        for(int tot=r+c;tot>=2;--tot) {
            for(int i=1;i<=r;++i) {
                int j=tot-i;
                if(1<=j&&j<=c&&abs(1-p[i][j][0])>0.000001) {//当前点必定能够走出迷宫,否则不可能进入,因为结果不超过1000000
                    dp[i][j]/=1-p[i][j][0];
                    dp[i][j-1]+=p[i][j-1][1]*dp[i][j];//用“我为人人”型更新状态
                    dp[i-1][j]+=p[i-1][j][2]*dp[i][j];
                }
            }
        }
        printf("%.3lf\n",dp[1][1]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值