【树状数组】poj2352 stars

Stars

题意:计算星星的等级,星星左下方的其他星星的数目就是那颗星星的等级(可以在同一水平线或竖直线上)。输入是按照 纵坐标从小到大顺序,若纵坐标相同则按横坐标从小到大

题解:因为x,y已经排序好,所以后输入的星星的不可能在先输入的星星左下,可以一边输入一边更新树状数组,c[i]表示的是树状元素中的值,sum(i)即可求出该位置左边一共有多少星星(先输入的星星一定不会在它上方,可以不考虑y),之后跟新这一点的值..需要注意的是,坐标有可能为0,而树状数组是从1开始的,所以对应的x+1再传入树状数组中,防止TLE.

#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<cstdio>
#include<queue>
#include <iomanip>
#include <cmath>

using namespace std;
#define ALL(x) (x.begin(),x.end());
#define PI acos(-1,0);
typedef long long ll;
const int MAXN = 35000;
const int MAXL = 32000;
int c[MAXN];
int ans[MAXL];
 
int lowbit(int p){
	return p&(p^(p-1));
}

int update(int p)
{
	while(p<=32001){
		c[p]++;
		p+=lowbit(p);
	}
}
int sum(int p)
{
	int sum=0 ;
	while(p>0){
		sum+=c[p];
		p-=lowbit(p);
	}
	return sum;
}

int main()
{	
	int n,x,y;
	scanf("%d",&n);
	memset(ans,0,sizeof(ans));
	memset(c,0,sizeof(c));
	for(int i=0;i<n;i++){
		scanf("%d%d",&x,&y);
		++ans[sum(x+1)];
		update(x+1);
	}
		for(int i=0;i<n;i++){
		printf("%d\n",ans[i]);
	}
	return 0;
}

Astronomers often examine star maps where stars arerepresented by points on a plane and each star has Cartesian coordinates. Letthe level of a star be an amount of the stars that are not higher and not tothe right of the given star. Astronomers want to know the distribution of thelevels of the stars. 

For example, look at the map shown on the figure above. Level of the star number5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And thelevels of the stars numbered by 2 and 4 are 1. At this map there are only onestar of the level 0, two stars of the level 1, one star of the level 2, and onestar of the level 3. 

You are to write a program that will count the amounts of the stars of eachlevel on a given map.

Input

The first line of the input file contains a number ofstars N (1<=N<=15000). The following N lines describe coordinates ofstars (two integers X and Y per line separated by a space,0<=X,Y<=32000). There can be only one star at one point of the plane.Stars are listed in ascending order of Y coordinate. Stars with equal Ycoordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line.The first line contains amount of stars of the level 0, the second does amountof stars of the level 1 and so on, the last line contains amount of stars ofthe level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0

Hint

This problem has huge input data,use scanf() instead ofcin to read data to avoid time limit exceed.


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值