Stars(树状数组)

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

解题思路

本题的输入是按y坐标升序,y坐标相同时x坐标升序输入的,前面输入的点的y坐标肯定不大于当前点,所以后输入的点不会影响前面输入点的等级。

sum[]是构造的树状数组,星星的等级是从0级开始的,数星星算等级时自己是不算的,

所以算当前星星的等级只要求现在 x坐标小于它的星星个数就行了


AC代码

#include<stdio.h>
#include<string.h>
const int N=32010;                          //const 限定一个变量不允许改变
int sum[N], level[N];

int lowbit(int x)
{
    return x&(-x);
}

int get_sum(int x)                        //横坐标小于等于x的星星的总个数,
{
    int s=0;
    while( x>0 )
    {
        s += sum[x];
        x -= lowbit(x);
    }
    return s;
}

void update(int x)
{
    while( x<N )
    {
        sum[x]++;
        x += lowbit(x);
    }
}

int main()
{
    int n, x, y, i;
    scanf("%d",&n);

    memset(sum, 0, sizeof(sum));
    memset(level, 0, sizeof(level));
    for(i=0; i<n; i++)
    {
        scanf("%d%d", &x, &y);
        level[ get_sum(x+1) ]++;
        update(x+1);                            //先计数再更新,不然就把自己算在内了
    }
    for(i=0; i<n; i++)                          //特别注意,星星的等级是从0级开始的
        printf("%d\n", level[i]);

    return 0;
}


 
 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值