【树状数组】poj2352 stars

Stars

题意:计算星星的等级,星星左下方的其他星星的数目就是那颗星星的等级(可以在同一水平线或竖直线上)。输入是按照 纵坐标从小到大顺序,若纵坐标相同则按横坐标从小到大

题解:因为x,y已经排序好,所以后输入的星星的不可能在先输入的星星左下,可以一边输入一边更新树状数组,c[i]表示的是树状元素中的值,sum(i)即可求出该位置左边一共有多少星星(先输入的星星一定不会在它上方,可以不考虑y),之后跟新这一点的值..需要注意的是,坐标有可能为0,而树状数组是从1开始的,所以对应的x+1再传入树状数组中,防止TLE.

#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<cstdio>
#include<queue>
#include <iomanip>
#include <cmath>

using namespace std;
#define ALL(x) (x.begin(),x.end());
#define PI acos(-1,0);
typedef long long ll;
const int MAXN = 35000;
const int MAXL = 32000;
int c[MAXN];
int ans[MAXL];
 
int lowbit(int p){
	return p&(p^(p-1));
}

int update(int p)
{
	while(p<=32001){
		c[p]++;
		p+=lowbit(p);
	}
}
int sum(int p)
{
	int sum=0 ;
	while(p>0){
		sum+=c[p];
		p-=lowbit(p);
	}
	return sum;
}

int main()
{	
	int n,x,y;
	scanf("%d",&n);
	memset(ans,0,sizeof(ans));
	memset(c,0,sizeof(c));
	for(int i=0;i<n;i++){
		scanf("%d%d",&x,&y);
		++ans[sum(x+1)];
		update(x+1);
	}
		for(int i=0;i<n;i++){
		printf("%d\n",ans[i]);
	}
	return 0;
}

Astronomers often examine star maps where stars arerepresented by points on a plane and each star has Cartesian coordinates. Letthe level of a star be an amount of the stars that are not higher and not tothe right of the given star. Astronomers want to know the distribution of thelevels of the stars. 

For example, look at the map shown on the figure above. Level of the star number5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And thelevels of the stars numbered by 2 and 4 are 1. At this map there are only onestar of the level 0, two stars of the level 1, one star of the level 2, and onestar of the level 3. 

You are to write a program that will count the amounts of the stars of eachlevel on a given map.

Input

The first line of the input file contains a number ofstars N (1<=N<=15000). The following N lines describe coordinates ofstars (two integers X and Y per line separated by a space,0<=X,Y<=32000). There can be only one star at one point of the plane.Stars are listed in ascending order of Y coordinate. Stars with equal Ycoordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line.The first line contains amount of stars of the level 0, the second does amountof stars of the level 1 and so on, the last line contains amount of stars ofthe level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0

Hint

This problem has huge input data,use scanf() instead ofcin to read data to avoid time limit exceed.


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值