【线段树】Count the Colors (zoj 1610)

Count the Colors

Time Limit: 2 Seconds       Memory Limit: 65536 KB

(zoj 1610)

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1








大概翻译一下题目,就是每组数据给定n组修改,每次修改三个参数x,y,z,表示把线段[x,y]染成颜色z,注意是线段集合,不是点集合!问最后每种颜色有多少个连续的线段


用cc来维护颜色,-1表示未染色;>=0表示染色,并且是纯色;那么如果他的子节点的颜色各不相同的话,我们就应该把它标记成杂色-2
很明显,要用到懒标记来传递,这就是为什么要标记-2的原因,如果是-2的话就不能向下传递了,因为他的子节点都有各自的颜色了

最后就是统计,我们用一个sum[]来维护,只需要从根节点来一次遍历即可,遇到叶节点就判断该颜色与上一次的颜色last是否相同,不同则颜色数+1,并更新last,否则无视他。。。。。

最后输出(格式一点要对啊~~在zoj上第一次交出现了一个 Presentation Error,害得我查了很久的错。。。。。)



C++ Code
/*
C++ Code
http://blog.csdn.net/jiangzh7
By Jiangzh
*/
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int MAXN=8000+10;

int n;
int pmax,cmax;
int x[MAXN],y[MAXN],z[MAXN];
int cc[4*MAXN];
int sum[MAXN];
int last;

void read()
{
	freopen("zoj1610.in","r",stdin);
	freopen("zoj1610.out","w",stdout);
}

void change(int p,int l,int r,int a,int b,int c)
{
	if(a<=l && b>=r) {cc[p]=c;return;}
	if(cc[p]>=-1)
	{
		cc[p<<1]=cc[(p<<1)+1]=cc[p];
		cc[p]=-2;
	}
	int m=(l+r)>>1;
	if(a<m) change(p<<1,l,m,a,b,c);
	if(b>m) change((p<<1)+1,m,r,a,b,c);
}

void countall(int p,int l,int r)
{
	//printf("%d %d %d\n",p,l,r);
	if(r-l==1)//叶节点
	{
	    if(cc[p]!=last)
			{sum[cc[p]]++;last=cc[p];}
		return;
	}
	if(cc[p]>=-1)//传递标记
		cc[p<<1]=cc[(p<<1)+1]=cc[p];
	int m=(l+r)>>1;
	countall(p<<1,l,m); countall((p<<1)+1,m,r);
}

void work()
{
	memset(cc,-1,sizeof(cc));
	memset(sum,0,sizeof(sum));
	pmax=0;cmax=0;
	for(int i=1;i<=n;i++)
	{
		scanf("%d%d%d",&x[i],&y[i],&z[i]);
		pmax=max(pmax,y[i]);cmax=max(cmax,z[i]);
	}
	for(int i=1;i<=n;i++) change(1,0,pmax,x[i],y[i],z[i]);
	
	last=-1;
	countall(1,0,pmax);
	for(int i=0;i<=cmax;i++)
	    if(sum[i]) printf("%d %d\n",i,sum[i]);
	printf("\n");
}

int main()
{
	read();
	while(cin>>n) work();
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值