poj 2488 A Knight's Journey

7 篇文章 0 订阅
A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34677 Accepted: 11835

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany
问是否能马跳整个图,dfs就行



                   .-' _..`.
                  /  .'_.'.'
                 | .' (.)`.
                 ;'   ,_   `.
 .--.__________.'    ;  `.;-'
|  ./               /
|  |               / 
`..'`-._  _____, ..'
     / | |     | |\ \
    / /| |     | | \ \
   / / | |     | |  \ \
  /_/  |_|     |_|   \_\
 |__\  |__\    |__\  |__\

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
int xx[9]={0,-2,-2,-1,-1,1,1,2,2};
int yy[9]={0,-1,1,-2,2,-2,2,-1,1};
int mp[50][50];
int T,m,n,flag;
struct path
{
	int x,y;
}p[233];
bool check(int x,int y)
{
	if(x>0&&y>0&&x<=n&&y<=m&&mp[x][y]==0) return true;
	return false;
}
void dfs(int x,int y,int step)
{
	p[step].x=x;
	p[step].y=y;
	//cout<<x<<" "<<y<<" "<<step<<endl;
	if(step==m*n)
	{
		flag=1;
		return ;
	}
	for(int i=1;i<=8;i++)
	{
		if(check(x+xx[i],y+yy[i]))
		{
			mp[x+xx[i]][y+yy[i]]=1;
			dfs(x+xx[i],y+yy[i],step+1);
			if(flag) return ;
			mp[x+xx[i]][y+yy[i]]=0;
		}
	}
}

int main()
{
	cin>>T;
	int _case=0;
	while(T--)
	{
		cout<<"Scenario #"<<++_case<<":"<<endl;
		cin>>m>>n;
		flag=0;
		memset(mp,0,sizeof(mp));
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				memset(mp,0,sizeof(mp));
				mp[i][j]=1;
				dfs(i,j,1);
				if(flag) break;
				mp[i][j]=0;
			}
			if(flag) break;
		}
		if(!flag) cout<<"impossible"<<endl<<endl;
		else
		{
			for(int i=1;i<=m*n;i++)
				cout<<(char)(p[i].x+'A'-1)<<p[i].y;
			cout<<endl<<endl;
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值