PAT(甲级)1070

1070. Mooncake (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45

#include <iostream>
#include <algorithm>
#define MAX 1003

using namespace std;

//the amount of mooncakes should be represented by float type;
//
//

struct Mooncake{
	double tons;
	double price;
	double average;
};

bool cmp(const Mooncake &c1,const Mooncake &c2){
	return c1.average > c2.average;
}

Mooncake a[MAX];

int main()
{
	int N,D;
	int i;
	double profit=0.0;
//	freopen("test.txt","r",stdin);
	cin >>N >>D;
	for(i=0;i<N;i++)
	    cin >>a[i].tons;
	for(i=0;i<N;i++){
		cin >>a[i].price;
		a[i].average = a[i].price/a[i].tons;
	}
	sort(a,a+N,cmp);
    i = 0;
    while(i<N && a[i].tons <= D){
    	profit += a[i].price;
    	D -= a[i].tons;
    	i++;
	}
	if(D && i<N)
	    profit += a[i].price*D/a[i].tons;
//	fclose(stdin);
	printf("%.2lf\n",profit);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值