hdu 4004 The Frog's Games

The annual Games in frogs’ kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog’s longest jump distance).

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

Output
For each case, output a integer standing for the frog’s ability at least they should have.

Sample Input
6 1 2
2
25 3 3
11
2
18

Sample Output
4
11

大意,一条河长L,中间有n个石头,现在问,青蛙每次最少跳多少距离,能在m次之内跳过河。

大致思路。以0和河长L为上下界进行二分,对于每个mid,判断以这个mid作为最小步长,需要多次才能跳过河。

注意的问题。在对每个mid判断跳过河需要的步数时,如果任意两块石头之间的距离超过mid,则说明跳不过河。用last记录最后一个需要调到的石头,从0开始。当第i个石头到last的距离超过mid时,计步器cnt+1,然后把i的上一块石头标记为last。需要注意的时候,此时,应当从第i块石头开始继续往后遍历,由于for循环中i++自增了,所以此时,i应该先自减一次。

代码

#include<stdio.h>
#include<algorithm>
using namespace std;

int l,n,m;
int a[50009];

bool fun(int mid)
{
    int cnt=0,last=0;
    for(int i=1;i<=n+1;i++)
    {
        if(a[i]-a[i-1]>mid)
            return false;
        else
        {
            if(a[i]-a[last]<=mid)
                continue;
            else
            {
                cnt++;
                last=--i;
            }
        }
    }
    cnt++;
    if(cnt<=m) return true;
    else return false;
}

int main()
{
    while(~scanf("%d%d%d",&l,&n,&m))
    {
        a[0]=0;
        for(int i=1;i<n+1;i++)
            scanf("%d",&a[i]);
        a[n+1]=l;
        sort(a+1,a+1+n);
        int le=0,ri=l,mid;
        while(le<=ri)
        {
            mid=(le+ri)/2;
            if(fun(mid))
                ri=mid-1;
            else
                le=mid+1;
        }
        printf("%d\n",le);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值