Rightmost Digit hdoj 1061


Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31610    Accepted Submission(s): 12095


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
2
3
4
 

Sample Output
7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
 

Author

/*
Time Limit Exceeded
不过还是可以用来找规律的

#include<cstdio>
#include<stdlib.h>
int main()
{
    int T;
 scanf("%d",&T);
 while(T--)
 { 
    int n,i;
     __int64 s;
   scanf("%d",&n);
   s=n;
  for(i=1;i<n;++i)
  {    
      s%=10;
      s=(s%10)*(n%10);
  
   
     }
  printf("%I64d\n",s%10);
 }
return 0;
}
*/
/*
这种能AC
前30号  :
 (0,0), (1,1), (2,4), (3,7), (4,6), (5,5),(6,6), (7,3), (8,6), (9,9)
(10,0),(11,1),(12,6),(13,3),(14,6),(15,5),(16,6),(17,7),(18,4),(19,9)
(20,0),(21,1),(22,4),(23,7),(24,6),(25,5),(26,6),(27,3),(28,6),(29,9)

写到这儿,就明白了
*/


#include<stdio.h>
int main()
{
 int T;
 int a[]={0,1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9};
 scanf("%d",&T);
 while(T--)
 {
  __int64 n;
  scanf("%I64d",&n);
  printf("%d\n",a[n%20]);
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值