HDU - 1061 Rightmost Digit

Description

Given a positive integer N, you should output the most right digit of N^N. 
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 
 

Output

For each test case, you should output the rightmost digit of N^N. 
 

Sample Input

    
    
2 3 4
 

Sample Output

    
    
7 6

分析:这是一个a^b%c取余的问题,一般用快速幂取模算法解决。

首先我们知道 a^b%c = (a%c)^b %c

b分奇数和偶数:

int ans = 1;

a = a % c;

if(b%2==1)

ans = (ans * a) mod c; //如果是奇数,要多求一步,可以提前算到ans中

k = (a*a) % c; //我们取a2而不是a

for(int i = 1;i<=b/2;i++)

{

ans = (ans * k) % c;

}

ans = ans % c;

上诉算法虽然在执行效率上有一定提升,但是依然会超时,下面介绍快速幂:



实际上是把b转换成了二进制,然后逐位求a幂,同时bi的值是0或1,当bi=0时a幂为1,当bi=1时a幂为a^(2^i),所以只需判断b的最低位是否为1即可,每次循环a幂实际上是在递增的,相当于通项,这样效率会极大的提高。


下面是代码:

#include <cstdio>

int mod_exp(int a, int b, int c)
{
    int res = 1 % c, t = a % c;
    while(b)
    {
        if(b & 1) res = res * t % c;
        t = t * t % c;  //通项
        b >>= 1;
    }
    return res;
}

int main()
{
	int T;
	scanf("%d",&T);
	while(T--) {
        int n;
        scanf("%d",&n);
        printf("%d\n", mod_exp(n, n, 10));
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值