BFS示例—寻找奶牛

Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


——————————————————————————————————————————————————————————————————————
这道题目是一道简单的BFS题,寻找最少步数。题意就是说输入农场主和牛的位置,农场主可以让自己的坐标乘以2,可以减去1,可以加上1,就这三种方法,要找出到达奶牛的最少步数。BFS需要使用到队列,需要用到c++
代码实现:

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#include<math.h>
using namespace std;
const int maxn=1000000+5;
int n,m;
bool vst[maxn]; 

struct node
{
	int x,step;
}t;


void bfs(struct node b)
{
	queue <struct node> q;
	struct node now,next;
	b.step=0;
	q.push(b);
	while(!q.empty())
	{
		now=q.front();
		if(now.x==m)
		{
			printf("%d\n",now.step);
			return;
		}
		next.step=now.step+1;
		for(int i=0;i<3;i++)//三种情况循环三次
		{
			if(i==0)
			{
				next.x=now.x+1;//生成新的坐标
				if(!vst[next.x]&&next.x>=0&&next.x<=100000)//检查坐标是否越界是否走过
				{
					q.push(next);
					vst[next.x]=1;
				} 
			}
			else if(i==1)
			{
				next.x=now.x-1;
				if(!vst[next.x]&&next.x>=0&&next.x<=100000)
				{
					q.push(next);
					vst[next.x]=1;
				} 
			}
			else
			{
				next.x=2*now.x;
				if(!vst[next.x]&&next.x>=0&&next.x<=100000)
				{
					q.push(next);
					vst[next.x]=1;
				} 
			}
		}
		q.pop();
	}
	return;
}

int main()
{
	while(scanf("%d%d",&t.x,&m)!=EOF)
	{
		for(int i=0;i<100010;i++)
		{
			vst[i]=0;
		}
		if(t.x>=m)
			printf("%d\n",t.x-m);
		else
			bfs(t);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值