ZOJ-3956-Course Selection System【01背包】【17th浙大校赛】

Course Selection System


There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1, x2, …, xm, then his comfort level of the semester can be defined as follows:
这里写图片描述
Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n ≤ 500) – the number of cources.

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).

It is guaranteed that the sum of all n does not exceed 5000.

We kindly remind you that this problem contains large I/O file, so it’s recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input

2
3
10 1
5 1
2 10
2
1 10
2 10

Sample Output

191
0

题目链接:ZOJ-3956

题目大意:给出一系列H和对应的C,选其中几个:

记:s = 各h的和;  t = 各c的和

使得:s * s - s * t - t * t 最大

题目思路:比赛的时候没写出来,一直往贪心的方向去想了。。实际上我们可以发现在t的值一定的时候,s越大越好。而且题目中给出c的范围也很小(100)。所以背包就行了!

以下是代码:

#include <iostream>
#include <iomanip>
#include <fstream>
#include <sstream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cctype>
#include <algorithm>
#include <functional>
#include <numeric>
#include <string>
#include <set>
#include <map>
#include <stack>
#include <vector>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
using namespace std;
#define maxn 50050
long long dp[maxn];
long long h[maxn],c[maxn];
int main() {

    int _;
    cin >> _;
    while(_--)
    {
        int n;
        scanf("%d",&n);
        int maxc = 0;
        memset(dp, 0, sizeof dp);
        for (int i = 0; i < n; i++)
        {
            scanf("%lld%lld",&h[i],&c[i]);
            maxc += c[i];
        }
        for (int i = 0; i < n; i++)
        {
            for (int j = maxc; j >= c[i]; j--)
            {
                dp[j] = max(dp[j], dp[j - c[i]] + h[i]);
            }
        }
        long long ans = 0;
        for (int i = 0; i <= maxc; i++)
        {
            ans = max(ans,dp[i] * dp[i] - dp[i] * i - i * i);
        }
        printf("%lld\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值