ZOJ 3956 Course Selection System

Course Selection System

Time Limit: 1 Second       Memory Limit: 65536 KB

There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1x2, ..., xm, then his comfort level of the semester can be defined as follows:

$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).

It is guaranteed that the sum of all n does not exceed 5000.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input
2
3
10 1
5 1
2 10
2
1 10
2 10
Sample Output
191
0
Hint

For the first case, Edward should select the first and second courses.

For the second case, Edward should select no courses.


Author:  WANG, Yucheng
Source:  The 17th Zhejiang University Programming Contest Sponsored by TuSimple

提示

题意:

从n个hi和ci中可不连续取任意个(意味着也可取0个)使得公式最后算出来的数值最大。

思路:

我们可以看做c固定不变的,要使得h尽可能的大,那么就可以转化为01背包问题。

示例程序

#include <stdio.h>
#include <string.h>
int main()
{
    int t,n;
    long long i,i1,dp[50001],h,c,max;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        for(i=1;n>=i;i++)
        {
            scanf("%lld %lld",&h,&c);
            for(i1=50000;i1>=c;i1--)			//这里的50000可优化为所有ci之和,减少循环次数,下同
            {
                if(dp[i1]<dp[i1-c]+h)
                {
                    dp[i1]=dp[i1-c]+h;
                }
            }
        }
        max=0;
        for(i=0;50000>=i;i++)
        {
            if(max<dp[i]*dp[i]-dp[i]*i-i*i)
            {
                max=dp[i]*dp[i]-dp[i]*i-i*i;
            }
        }
        printf("%lld\n",max);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值