Problem Description
There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1, x2, ..., xm, then his comfort level of the semester can be defined as follows:
Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?
Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.
Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).
It is guaranteed that the sum of all n does not exceed 5000.
We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.
Output
For each case, you should output one integer denoting the maximum comfort.
Sample Input
2
3
10 1
5 1
2 10
2
1 10
2 10Sample Output
191
0Hint
For the first case, Edward should select the first and second courses.
For the second case, Edward should select no courses.
题意:t 组数据,每组给出 n 门课,第 i 门课给出两个值 Hi、Ci,对于每门课可以选也可以不选,最后要求算一个结果,其计算公式如上,其中 m 是所有选的课,求最大的结果
思路:
对于所给公式,设
那么有:
化简后有: 可视为开口向下的抛物线,故只要令 尽量大即可
对 化简,有:
要使 那么就要让 尽量大, 尽量小,即令 尽量大, 尽量小
再考虑第 i 门课可以放也可以不放,那么原问题可以转化为 01 背包问题,即:对于第 i 物品来说,可以选也可以不选,令 Hi 为物品价值,Ci 为物品重量,物品重量从 1 到 500*100=50000,最后枚举结果的最大值即可
要注意的是,由于所有的课都可以不选,那么结果的最小值最小为 0,不可能为负数
Source Program
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define EPS 1e-9
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
const int MOD = 1E9+7;
const int N = 50000+5;
const int dx[] = {0,0,-1,1,-1,-1,1,1};
const int dy[] = {-1,1,0,0,-1,1,-1,1};
using namespace std;
LL h[N],c[N];
LL f[N];
int main() {
int t;
scanf("%d",&t);
while(t--) {
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%lld%lld",&h[i],&c[i]);
memset(f,0,sizeof(f));
for(int i=1;i<=n;i++){
for(LL j=50000;j>=c[i];j--)
f[j]=max(f[j],f[j-c[i]]+h[i]);
}
LL maxx=0;
for(LL i=1;i<=50000;i++)
maxx=max(maxx,(LL)(f[i]*f[i])-(LL)(i*f[i])-(LL)(i*i));
printf("%lld\n",maxx);
}
return 0;
}