POJ 2010 Moo University - Financial Aid (优先队列)

Moo University - Financial Aid
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5541 Accepted: 1659

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000). 

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible. 

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves. 

Input

* Line 1: Three space-separated integers N, C, and F 

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output

35

- - 因为要求中位数 并且N恒为奇数 那么预处理 前半 以及后半的最小和  那么我们需要优先队列

每次删除最大的那个 保证数目恒为N/2  这样然后从大到下 枚举一遍满足要求的即可~

AC代码如下:

//
//  POJ 2010 Moo University - Financial Aid
//
//  Created by TaoSama on 2015-03-16
//  Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>
#define CLR(x,y) memset(x, y, sizeof(x))

using namespace std;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1e5 + 10;

int n, m, f;
pair<int, int> cow[N];
int l[N], h[N];

int main() {
#ifdef LOCAL
	freopen("in.txt", "r", stdin);
//	freopen("out.txt","w",stdout);
#endif
	ios_base::sync_with_stdio(0);

	while(cin >> n >> m >> f) {
		for(int i = 1; i <= m; ++i)
			cin >> cow[i].first >> cow[i].second;
		int half = n >> 1;
		sort(cow + 1, cow + 1 + m);

		{
			int total = 0;   //前半最小和
			priority_queue<int> pq;
			for(int i = 1; i <= m; ++i) {
				l[i] = pq.size() == half ? total : INF;
				pq.push(cow[i].second);
				total += cow[i].second;
				if(pq.size() > half) {
					total -= pq.top();
					pq.pop();
				}
			}
		}
		{
			int total = 0;		//后半最小和
			priority_queue<int> pq;
			for(int i = m; i >= 1; --i) {
				h[i] = pq.size() == half ? total : INF;
				pq.push(cow[i].second);
				total += cow[i].second;
				if(pq.size() > half) {
					total -= pq.top();
					pq.pop();
				}
			}
		}

		int ans = -1;
		for(int i = m; i >= 1; --i) {
			if(l[i] + cow[i].second + h[i] <= f) {
				ans = cow[i].first;
				break;
			}
		}
		cout << ans << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值