HDU-1312-Red and Black

16 篇文章 0 订阅

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1312


Red and Black

                                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                   Total Submission(s): 20660    Accepted Submission(s): 12559


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 
分析:m*n的地图,‘@’为起点,‘.’为路,‘#’为墙,问能到达多少地方。注意在输入时第一个数为列,第二个数为行。

可以用dfs或bfs。

dfs代码如下:

#include<iostream>
using namespace std;
char mp[21][21];
int n,m,sum;
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
bool check(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m&&mp[x][y]=='.')
        return 1;
    else
        return 0;
}
void dfs(int si,int sj)
{
    for(int i=0;i<4;i++)
    {
        int xx=si+dir[i][0];
        int yy=sj+dir[i][1];
        if(check(xx,yy))
        {
            sum++;
            mp[xx][yy]='#';
            dfs(xx,yy);//不需要把搜过的点还原。 
        }
    }
}
int main()
{
    int si,sj;
    while(cin>>m>>n)
    {
        if(n==0&&m==0)
            break;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                cin>>mp[i][j];
                if(mp[i][j]=='@')
                {
                    si=i;
                    sj=j;
                }
            }
        }
        sum=1;
        mp[si][sj]='#';
        dfs(si,sj);
        cout<<sum<<endl;
    }
    return 0;
}

bfs代码如下:

#include<iostream>
#include<queue>
using namespace std;
char mp[21][21];
int dir[4][2]={{-1,0},{1,0},{0,1},{0,-1}};
int n,m,sum;
struct node{
	int x,y;
};
bool check(node t)
{
    if(t.x>=0&&t.x<n&&t.y>=0&&t.y<m&&mp[t.x][t.y]=='.')
        return 1;
    else
        return 0;
}
bool bfs(int sx,int sy)
{
	queue<node>q;
	node now,next;
	now.x=sx;
	now.y=sy;
	q.push(now);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			next.x=now.x+dir[i][0];
			next.y=now.y+dir[i][1];
			if(check(next))
			{
				mp[next.x][next.y]='#';
				sum++;
				q.push(next);
			}
		}
	}
}
int main()
{
    int si,sj;
    while(cin>>m>>n)
    {
        if(n==0&&m==0)
            break;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                cin>>mp[i][j];
                if(mp[i][j]=='@')
                {
                    si=i;
                    sj=j;
                }
            }
        }
        sum=1;
        //mp[si][sj]='#';
        bfs(si,sj);
        cout<<sum<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值