Fzu 1752 A^B mod C【快速幂+快速积+细节处理】

Problem 1752 A^B mod C

Accept: 909    Submit: 3972
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

Output

For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input

3 2 42 10 1000

Sample Output

124

Source

FZU 2009 Summer Training IV--Number Theory 

题目大意:

计算出a^b%c的值。


思路1、

快速幂+快速积+细节代码处理。
①判断奇偶性的时候要用位运算处理
②处理取摸的时候不用%而用减法。

快速积:快速幂中乘法变加法。

然后就能开开心心的900+ms AC

#include<stdio.h>
#include<string.h>
using namespace std;
#define ll __int64
ll a,b,c,mod;
ll kuaisucheng(ll a,ll b)
{
    ll ans=0;
    while(b)
    {
        if(b&1)
        {
            ans=(ans+a);
            if(ans>=mod)ans-=mod;
        }
        a=(a+a);
        if(a>=mod)a-=mod;
        b/=2;
    }
    return ans;
}
int main()
{
    while(~scanf("%I64d%I64d%I64d",&a,&b,&c))
    {
        a%=c;
        mod=c;
        ll ans=1;
        while(b)
        {
            if(b&1)
            {
                ans=kuaisucheng(ans,a);
            }
            a=kuaisucheng(a,a);
            b/=2;
        }
        printf("%I64d\n",ans);
    }
}


思路2:、

来自巨巨Claris的黑科技:O(1)快速积

Ac代码:


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
using namespace std;
#define ll __int64
ll a,b,c,mod;
ll kuaisucheng(ll a,ll b)
{
    a%=mod;
    b%=mod;
    return (a*b-(ll)(a/(long double )mod*b+1e-8)*mod+mod)%mod;
}
int main()
{
    while(~scanf("%I64d%I64d%I64d",&a,&b,&c))
    {
        a%=c;
        mod=c;
        ll ans=1;
        while(b)
        {
            if(b%2==1)
            {
                ans=kuaisucheng(ans,a)%mod;
                b-=1;
            }
            a=kuaisucheng(a,a)%mod;
            b/=2;
        }
        printf("%I64d\n",ans);
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值