LA3700 Interesting Yang Hui Triangle(Lucas定理)

Harry is a Junior middle student. He is very interested in the story told by his mathematics teacher about the Yang Hui triangle in the class yesterday. After class he wrote the following numbers to show the triangle our ancestor studied.


                         1
                    1         1
                1        2        1
            1       3         3       1
         1      4        6        4      1
      1     5       10        10      5     1
   1     6      15       20       15     6     1
1     7     21      35        35      21    7     1
                       ......


He found many interesting things in the above triangle. It is symmetrical, and the first and the last numbers on each line is 1; there are exactly i numbers on the line i.

Then Harry studied the elements on every line deeply. Of course, his study is comprehensive.

Now he wanted to count the number of elements which are the multiple of 3 on each line. He found that the numbers of elements which are the multiple of 3 on line 2, 3, 4, 5, 6, 7, ... are 0, 0, 2, 1, 0, 4, ... So the numbers of elements which are not divided by 3 are 2, 3, 2, 4, 6, 3, ... , respectively. But he also found that it was not an easy job to do so with the number of lines increasing. Furthermore, he is not satisfied with the research on the numbers divided only by 3. So he asked you, an erudite expert, to offer him help. Your kind help would be highly appreciated by him.

Since the result may be very large and rather difficult to compute, you only need to tell Harry the last four digits of the result.

Input 

There are multiple test cases in the input file. Each test case contains two numbers P and N , (P < 1000, N$ \le$109) , where P is a prime number and N is a positive decimal integer.

P = 0N = 0 indicates the end of input file and should not be processed by your program.

Output 

For each test case, output the last four digits of the number of elements on the N + 1 line on Yang Hui Triangle which can not be divided by P in the format as indicated in the sample output.

Sample Input 

3 4 
3 48 
0 0

Sample Output 

Case 1:  0004
Case 2:  0012

题意:杨辉三角第n行的n+1个数有多少个数可以被p整除
思路:将n,m转化成p进制,每一位分别为(a1,a2,a3,a4.....) ,(b1,b2,b3,b4.....)
C(n,m)%p  =  C(a1,b1)*C(a2,b2)*C(a3,b3)......%p
要使C(ai,bi) = 0 只有当bi>ai ,因此求不能整除的数的个数可以通过 (ai+1)累乘(计数原理)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
int p,n;
int ans;
vector<int> digit;
int main(){
    int T = 1;
    while(~scanf("%d%d",&p,&n) && p+n){
        digit.clear();
        ans = 1;
        while(n){
            digit.push_back(n%p);
            n /= p;
        }
        for(int i = 0; i < digit.size(); i++){
            ans = (ans*(digit[i]+1))%10000;
        }

        printf("Case %d: %04d\n",T++,ans);
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值