Ubuntu环境下利用Python3+PyQt5+Eric6进行GUI编程

原创 2015年11月21日 10:24:26

首先当然是要配置环境啦,这里特别感谢@ideber的文章,安装过程已经非常详细了。

 

原文地址:http://blog.csdn.net/idber/article/details/40076821


下面贴出一些我在安装过程中遇到的问题:


1.安装PyQt5时失败,提示:This version of PyQt5 and the commercial version of Qt have incompatible licenses.

网上都说开源版本有自带的GPL协议,我也不知道为什么这里还会有这一项提示,于是就只好向度娘求救啦,自然是功夫不负有心人

解决方法:在解压后的PyQt文件夹中找到configure.py文件并打开,将2590行之后的下面这一段代码注释掉就OK啦

    # Common checks.
    if introspecting and target_config.qt_licensee != 'Open Source' and ltype == 'GPL':
        error(
                "This version of PyQt5 and the commercial version of Qt have "
                "incompatible licenses.")


 

2.为保证PyQt5能够正常使用,安装前需配置依赖环境

<strong>解决方法</strong>:sudo apt-get install PyQt5-dev



3.同样,在安装Qscintilla2前也需配置相应环境

解决方法:sudo apt-get install libqscintilla2*

为了省事,我就不管三七二十一把相关的包都装上了


还有一些问题没来得及记录,不过度娘是万能的你懂的~.~

接下来就是愉快的编程啦~~


版权声明:本文为博主原创文章,未经博主允许不得转载。

 

版权声明:本文为博主原创文章,未经博主允许不得转载。

[Ubuntu--Install]Ubuntu16.04下搭建python3.5+PyQt5.7+Eric6开发环境

简述原来在windows下实现的python code,因为业务需要,要将其放到Ubuntu(其实是Linux)下来进行开发和demo。因此安装了目前最新的Ubuntu16.04 64bit系统,并搭...
  • suxiang198
  • suxiang198
  • 2016年07月27日 23:44
  • 10409

ubuntu 安装pyqt IDE使用eric 辛酸史

ubuntu 12.4 下安装pyqt   所有的下载都是最新的。 按照网上的教程yi bu
  • qq61394323
  • qq61394323
  • 2014年07月16日 22:06
  • 4975

Anaconda+pyqt+Eric6

因为要在windows下安装python版本的labelme,所以安装了Anaconda。为了修改labelme的源代码,就必须安装pyqt4/5.心塞的留下笔记。分别在windows和ubuntu下...
  • u010069760
  • u010069760
  • 2017年09月30日 11:19
  • 468

完美安装 Anaconda3 + PyQt5 + Eric6

PyQt5与Eric6是众所周知的Python平台下用来快速开发GUI程序的绝配。 可是刚接触这些的朋友在安装上因为模块的依赖性往往会遇到很多问题,有些问题甚至于搞的人头大。 因为Anaconda...
  • weiaitaowang
  • weiaitaowang
  • 2016年07月27日 14:42
  • 20270

PyQt5+Eric6+Anaconda+Pycharm 开发Qt应用环境搭建

关于有些小盆友,一直不知道PyQt怎么开发,怎麽搭建环境,通过经验、资料总结一下。     首先来讲,我也是初学,如果你是大神,建议别浪费时间。 一、安装Anaconda ,别问为什么,因为懒省事儿!...
  • xh21bao
  • xh21bao
  • 2017年04月09日 15:24
  • 2456

Ubuntu环境下利用Python3+PyQt5+Eric6进行GUI编程

首先当然是要配置环境啦,这里特别感谢@ideber的文章,安装过程已经非常详细了。   原文地址:http://blog.csdn.net/idber/article/details/400768...
  • neoalvin
  • neoalvin
  • 2015年11月21日 10:24
  • 841

Ubantu环境下利用Python3+PyQt5+Eric6进行GUI编程

首先当然是要配置环境啦,这里特别感谢@ideber的文章,安装过程已经非常详细了。 原文地址:http://blog.csdn.net/idber/article/details/40076821 ...
  • sir_alvin
  • sir_alvin
  • 2015年10月06日 18:32
  • 550

C++ GUI QT4 编程--gotocell2 在QT5下编译出现的问题及解决

问题: Cannot find file: F:\Program\QT5\Program\C++GUI Qt4编程源代码\chap02\gotocell2\gotocell2.pro. 08:...
  • graduation201209
  • graduation201209
  • 2015年09月04日 08:56
  • 335

Ubuntu14.04 搭建PyQt4+Eric5 开发环境

Ubuntu1  1. Install Qt4 or Qt5 (from Nokia)                          2. Build and install...
  • u010685850
  • u010685850
  • 2014年11月05日 20:38
  • 1480

ubuntu 14.04+QT5.5+PyQt5.5+Eric-6开发环境搭建

去QT官网或者qtcn论坛下载最新的QT版本,然后安装.此步骤忽略. ubuntu系统自带了qmke,但是版本较低,要使用前面安装的最新版本QT中的qmake。 ```bash sudo ln -s...
  • ashimidashajia
  • ashimidashajia
  • 2015年10月06日 22:27
  • 2911
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Ubuntu环境下利用Python3+PyQt5+Eric6进行GUI编程
举报原因:
原因补充:

(最多只允许输入30个字)