HDU-1021-Fibonacci Again ( 找规律 + Fibonacci )

206 篇文章 0 订阅
78 篇文章 0 订阅
本文探讨了Fibonacci数列的特性,通过实例解析数列中的规律,并介绍了如何用C++和C语言实现Fibonacci序列的计算,适合ACM竞赛训练和HDU在线判题。
摘要由CSDN通过智能技术生成

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48846    Accepted Submission(s): 23168


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
 

Author
Leojay
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1061  1019  1108  1071  1170



不要老老实实去递归,它有1000000的数据....而int型的精度,算到 n = 40 多的时候......不仅速度奇慢无比......而且都计算出错了.
打40个数据的表......发现从第二个数据开始,每四个数据......一个yes。 虽然有时候感觉,也是不好......但是题目就是这样做的.
你用int去递归或者打表。肯定会溢出的。



 

//HDU_1021

#include<iostream>
#include<cstdio>
using namespace std;
int Fibonacci(int i)
{
    if(i==0)
        return 7;
    if(i==1)
        return 11;
    else
        return (Fibonacci(i-1)+Fibonacci(i-2));
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if((n-2)%4==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }

//    int n;
//    for(int i=0;i<40;i++)
//    {
//        cout<<i<<" ";
//        if(Fibonacci(i)%3==0)
//            cout<<"yes"<<endl;
//        else
//            cout<<"no"<<endl;
//    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值