hdu 2298 Toxophily (物理题)

Toxophily

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1281    Accepted Submission(s): 673


Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m.
 

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000.
 

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.

Please use radian as unit.
 

Sample Input
  
  
3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551
 

Sample Output
  
  
1.561582 -1 -1
 

Source
 题解转自

题目大意:Bob在(00)点想射在(x, y)点的水果,初始的速度为v(已知), g=9.8, 求最小的角度射到苹果

解题思路:

---直接推到物理公式:

将速度的分解为x方向和y方向,然后列出式子

1> x=vcosθ* t   ----变形---> t=x/vcosθ

2> y=vsinθ*t -g*t*t/2 

t的函数带入2>式中得  y=tanθ* x-g*x*x/(2*v*v*cos^2θ)  ---3

1/cos^2θ=(sin^2θ+cos^2θ)/cos^2θ= 1+tan^2θ ----带入3式中,得:

g*x*x*tan^2θ-2*v*v*x*tanθ+g*x*x+2*v*v*y=0

tanθ看成是未知数,那么a=g*x*x, b=-2*v*v*x, c=2*v*v*y+g*x*x;

Δ=b^2-4ac 先进行判断是否有根。如果没有根输出-1,否则根据求根公式

X1=[-b+Δ^(1/2)]/2a

X2=[-b-Δ^(1/2)]/2a

如果求的解不在[0. Π/2]内还是算无解。

:
点击打开链接
纯物理题,下面是我的挫代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#define PI acos(-1.0)
#define g 9.8

int main ( )
{
    int t;
    double x ,y , v;
    scanf ( "%d" , &t );
    while ( t-- )
    {
        scanf ( "%lf%lf%lf" , &x , &y , &v );
        double dd , x1 , x2 , a , b , c;
        a = g*x*x , b = -2*v*v*x , c = 2*v*v*y + g*x*x;
        dd = b*b-4*a*c;
        if ( dd < 0 )
           puts ( "-1" );
        else 
        {
            x1 = atan((-1*b+sqrt(dd))/(2*a));
            x2 = atan((-1*b-sqrt(dd))/(2*a));
            if ( (x1<0||x1>PI/2)  && (x2<0||x2>PI/2) )
                puts ( "-1" );
            else if ( x1 < 0 || x1 > PI/2 )
                printf ( "%.6lf\n" , x2 );
            else if ( x2<0||x2>PI/2)
                printf ( "%.6lf\n" , x1 );
            else 
                printf( "%.6lf\n" , x1<x2?x1:x2 );
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值