UVA 455 Periodic Strings

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF
 Periodic Strings 

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2

 Status


题意:

计算字符串周期的长度



#include<stdio.h>
#include<string.h>
int main (void)
{
    int T;
    char a[100];
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",a);
        int flag=0;
        int n=0;
        for(int i=1; i<=strlen(a); i++)
        {
            n=0;
            if(strlen(a)%i==0)//不加这一步貌似没影响 但是不加就一直WA  WA WA
            {
                for(int ii=0; ii<strlen(a); ii++)
                {
                    if(a[ii]==a[ii%i])
                    {
                        n++;
                        if(n==strlen(a))
                        {
                            printf("%d",i);
                            flag=1;
                            break;
                        }
                    }
                }
           }
            if(flag) break;
        }
        if(T)
            printf("\n\n");
        else
            printf("\n");

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值