HDOJ 1016 Prime Ring Problem(DFS)

Prime Ring Problem




Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
题目大意:给出一个有N个空位的圆环,每个空位填1到N之间的一个数,每个数只能使用一次,相邻两个位置的和必须为素数,且第一个位置必须填1。

解题思路:回溯法,注意输出格式以及递归终止条件的判定。

代码如下:

#include <cstdio>
#include <cmath>
#include <cstring>


const int maxn = 25;
int ring[maxn],visit[maxn];
int n;

bool isPrime(int ptr)
{
	if(ptr == 2)
		return true;
	for(int i = 2;i <= sqrt(1.0 * ptr);i++){
		if(ptr % i == 0)
			return false;
	}
	return true;
}

void dfs(int cur)
{
	if(cur == n + 1 && isPrime(ring[1] + ring[n])){//递归边界,注意判定第一个元素与最后一个元素 
		printf("%d",ring[1]);
		for(int i = 2;i <= n;i++){
			//注意输出格式,每行末尾没有空格,否则会PE 
			printf(" %d",ring[i]);
		}
		printf("\n");
	}else{
		for(int i = 2;i <= n;i++){
			if(!visit[i] && isPrime(i + ring[cur - 1])){
				ring[cur] = i;
				visit[i] = 1;//标记i已经被使用 
				dfs(cur + 1);
				visit[i] = 0;//清除使用标记 
			}
		}
	}
}

int main()
{
	int ncase = 0;
	while(scanf("%d",&n) != EOF){
		printf("Case %d:\n",++ncase);
		ring[1] = 1;
		dfs(2);
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值