CSUOJ 1726 你经历过绝望吗?两次!(BFS + 优先队列)

1726: 你经历过绝望吗?两次!


Description

4月16日,日本熊本地区强震后,受灾严重的阿苏市一养猪场倒塌,幸运的是,猪圈里很多头猪依然坚强存活。当地15名消防员耗时一天解救围困的“猪坚强”。不过与在废墟中靠吃木炭饮雨水存活36天的中国汶川“猪坚强”相比,熊本的猪可没那么幸运,因为它们最终还是没能逃过被送往屠宰场的命运。
我们假设“猪坚强”被困在一个N*M的废墟中,其中“@”表示“猪坚强”的位置,“.”表示可以直接通过的空地,“#”表示不能拆毁的障碍物,“*”表示可以拆毁的障碍物,那么请问消防员至少要拆毁多少个障碍物,才能从废墟中救出“猪坚强”送往屠宰场?(当“猪坚强”通过空地或被拆毁的障碍物移动到废墟边缘时,视作被救出废墟)

Input

多组数据,第一行有一个整数T,表示有T组数据。(T<=100)
以下每组数据第一行有两个整数N和M。(1<=N,M<=100)
接着N行,每行有一个长度为M的字符串。

Output

一个整数,为最少拆毁的障碍物数量,如果不能逃离废墟,输出-1。

Sample Input

3
3 3
###
#@*
***
3 4
####
#@.*
**.*
3 3
.#.
#@#
.#.

Sample Output

1
0
-1
解题思路:由于猪只有一个而出口不确定,所以我们可以从猪开始进行BFS,当猪到达4个边界时认定它被救出来。另外因为有些墙可以拆掉,所以BFS时要使用优先队列。

代码如下:

#include <algorithm>
#include <cctype>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <map>
#include <queue>
#include <set>
#include <stack>
#include <vector>
#define EPS 1e-6
#define INF INT_MAX / 10
#define LL long long
#define MOD 100000000
#define PI acos(-1.0)
using namespace std;

struct node
{
    int x,y;
    int step;
};

bool operator < (node p,node q)
{
    return p.step > q.step;
}

const int maxn = 111;
int n,m;
char maze[maxn][maxn];
int dir[4][2] = {{0,1},{-1,0},{0,-1},{1,0}};
int sx,sy;
int bfs()
{
    priority_queue<node> que;
    node p;
    p.x = sx,p.y = sy,p.step = 0;
    que.push(p);
    maze[sx][sy] = '#';
    while(que.size()){
        node q = que.top();
        que.pop();
        if(q.x == n - 1 || q.y == m - 1 || q.x == 0 || q.y == 0){
            return q.step;
        }
        for(int i = 0;i < 4;i++){
            node r;
            r.x = q.x + dir[i][0];
            r.y = q.y + dir[i][1];
            if(0 <= r.x && r.x < n && 0 <= r.y && r.y < m && maze[r.x][r.y] != '#'){
                if(maze[r.x][r.y] == '*')
                    r.step = q.step + 1;
                else
                    r.step = q.step;
                que.push(r);
                maze[r.x][r.y] = '#';
            }
        }
    }
    return -1;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&n,&m);
        for(int i = 0;i < n;i++)
            scanf("%s",maze[i]);
        for(int i = 0;i < n;i++){
            for(int j = 0;j < m;j++){
                if(maze[i][j] == '@'){
                    sx = i;
                    sy = j;
                    break;
                }
            }
        }
        printf("%d\n",bfs());
        memset(maze,0,sizeof(maze));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值