POJ 1985-Cow Marathon【树的直径模板】

Cow Marathon
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 4583 Accepted: 2265
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

解题思路:

树的直径,来,上模板。不用考虑最后那个方向,就是拿来逗人的。

#include <iostream>
#include<stdio.h>
#include <string.h>
#define MAXN 60005
#define INF 0x3f3f3f3f

using namespace std;

struct Edge
{
    int v, w, next;
}edge[MAXN*6];

int m,head[MAXN], vis[MAXN], d[MAXN], q[MAXN], e, n;

int init()
{
    e = 0;
    memset(head, -1, sizeof(head));
}

void add(int u, int v, int w)
{
    edge[e].v = v;
    edge[e].w = w;
    edge[e].next = head[u];
    head[u] = e++;
}

void bfs(int src)
{
    for (int i = 1; i <= n; i++)
    {
        vis[i] = 0;
        d[i] = INF;
    }

    int h = 0, t = 0;
    vis[src] = 1;
    q[t++] = src;
    d[src] = 0;
    while (h < t)
    {
        int u = q[h++];
        for (int i = head[u]; i != -1; i = edge[i].next)
        {
            int v = edge[i].v;
            int w = edge[i].w;
            if (d[u] + w < d[v])
            {
                d[v] = d[u] + w;
                if (!vis[v])
                {
                    q[t++] = v;
                    vis[v] = 1;
                }
            }
        }
    }
}

int main()
{
    int u, v, w;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		char pp;
	    for (int i=1;i<=m; i++)
	    {
	        scanf("%d%d%d %c",&u,&v,&w,&pp);
	        add(u, v, w);
	        add(v, u, w);
	    }
	    bfs(1);
	    int pos = 0, mx = -1;
	    for (int i  = 1; i <= n; i++)
	    {
	        if(d[i] > mx)
	        {
	            mx = d[i];
	            pos = i;
	        }
	    }
	    bfs(pos);
	    mx = -1;
	    for (int i  = 1; i <= n; i++)
	    {
	        if(d[i] > mx)
	        {
	            mx = d[i];
	        }
	    }
	    printf("%d\n",mx);
	} 
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值