ZOJ 1586 QS Network(最小生成树)

24 篇文章 1 订阅
5 篇文章 0 订阅

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS’s have received the message.

A sample is shown below:

A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS’s favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS’s favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0

Sample Output

370
论起来题目并不算太难,只是题目想要读懂的话有点难。
我跟大家解释一下题目大意吧:题目的意思是每个人有一个路由器,第二行给出的n的数代表的意思是n个人的路由器需要花多少钱。
下面给出的方阵的意思:比如第i行第j列的那个数字的意思是:i和j之间建立需要花费的网线费用。
另外注意一点是:每两点建立时的花费为两点的网线钱和两个路由器的花费。
另外,题目的意思是让你求出联立图中n个点的最小花费。
下面是AC 代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

struct node
{
    int u,v,cost;
}a[1000005];

int pre[1000005];
int fin(int x)
{
    if(pre[x]==x)
    {
        return x;
    }
    else
    {
        return pre[x]=fin(pre[x]);
    }
}

void join(int x,int y)
{
    int t1=fin(x);
    int t2=fin(y);
    pre[t1]=t2;
}

bool cmp(node x,node y)
{
    return x.cost<y.cost;
}

int luyoucost[1000005];
int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&luyoucost[i]);
            pre[i]=i;
        }
        int cnt=0,num;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&num);
                a[cnt].u=i,a[cnt].v=j;
                a[cnt].cost=num+luyoucost[i]+luyoucost[j];
                cnt++;
            }
        }
        int sum1=0,sum=0;
        sort(a,a+cnt,cmp);
        for(int i=0;i<cnt;i++)
        {
            if(fin(a[i].u)!=fin(a[i].v))
            {
                join(a[i].u,a[i].v);
                sum+=a[i].cost;
                sum1++;
            }
            if(sum1==n-1)
            {
                break;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值