poj 1287 (最小生成树 Prime + kruskal )

Networking
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8435 Accepted: 4649

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. 

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

Source


点击打开题目链接http://poj.org/problem?id=1287


题意:给出P个节点,再有R条边,这R条边代表从a节点到b节点电缆的长度为C,现在要你将所有节点都连起来,并且使长度最小
解题思路:这是个标准的最小生成树的问题,用prim的时候需要注意的是他有重边,取边最小的那条加入图里就可以了,但是kruskal可以忽略这个问题,这两个算是比较简单的了。


Prime:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#include <math.h>
typedef long long ll;
using namespace std;

#define INF 0x3f3f3f3f
#define N 110
int maps[N][N],vis[N],dis[N];
int P,R;

void init(int n)
{
    int i,j;
    for(i=0;i<=n;i++)
        for(j=0;j<=n;j++)
        maps[i][j]=(i==j)?0:INF;
}

int Prime(int s,int n)
{
    int i,j,index,Min,sum=0;
    for(i=1;i<=n;i++)
    {
        dis[i]=maps[1][i];
        vis[i]=0;
    }
    vis[s]=1;
    for(i=1;i<=n;i++)
    {
        Min=INF,index=-1;
        for(j=1;j<=n;j++)
        {
            if(!vis[j] && Min>dis[j])
            {
                Min=dis[j];
                index=j;
            }
        }
        if(index==-1)
            break;
        sum=sum+Min;
        vis[index]=1;
        for(j=1;j<=n;j++)
        {
            if(!vis[j] && dis[j]>maps[index][j])
                dis[j]=maps[index][j];
        }
    }
    return sum;
}

int main()
{
    int i,a,b,c;
    while(scanf("%d%d",&P,&R),P)
    {
        init(P);
        for(i=1;i<=R;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            maps[a][b]=maps[b][a]=min( maps[a][b], c);
        }
        int ans=Prime(1,P);
        printf("%d\n",ans);
    }
    return 0;
}


Kruskal:(并查集)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#include <math.h>
typedef long long ll;
using namespace std;

#define INF 0x3f3f3f3f
#define N 2510
int father[N];

struct edge
{
    int s,e,w;
}p[N];

int cmp(edge a,edge b)
{
    return a.w<b.w;
}

int Find(int x)
{
    while(x!=father[x])
        x=father[x];
    return x;
}

int main()
{
    int P,R,i,ans;
    while(scanf("%d%d",&P,&R),P)
    {
        for(i=1;i<=P;i++)
            father[i]=i;

        for(i=1;i<=R;i++)
            scanf("%d%d%d",&p[i].s,&p[i].e,&p[i].w);
        sort(p+1,p+R+1,cmp);

        ans=0;
        for(i=1;i<=R;i++)
        {
            int x,y;
            x=Find(p[i].s);
            y=Find(p[i].e);
            if(x==y)
                continue;
            else
            {
                ans=ans+p[i].w;
                father[x]=y;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值