POJ1276 多重背包

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36959 Accepted: 13408

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.  In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.  In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
 
多重背包~用两种思路做。
1.常规模板法:
   能用完全背包就用完全,不能就拆分成按系数1、2、4……2^k进行拆分用0-1背包,可以降低复杂度。具体见背包九讲。
   此题又被自己坑了。。因为在判断容量为0后就直接continue忘记后面还要scanf了- - 之前也出现过这种错。所以如果尽量等输入完成后,
再进行特判。
   
#include<iostream>
#include<cstring>
#define max(a,b) a>b?a:b
using namespace std;
int f[100002];
int main(){
	int C,n;
	while(~scanf("%d%d",&C,&n)){
	
//		if(!n){
//			printf("0\n");
//			continue;
//		}	
		memset(f,0,sizeof(f));
		for(int i = 0;i<n;i++){
			int vi,ni;
			scanf("%d%d",&ni,&vi);
			if(!vi || !ni) continue;
			if(vi*ni>=C){  //用完全背包
				for(int j = vi;j<=C;j++){
					f[j] = max(f[j],f[j-vi]+vi);
				} 	
			}
			else{ 			//多重背包
				int k = 1;
				while(k<ni){
					int val = k*vi;
					for(int j = C;j>=val;j--){
						f[j] = max(f[j],f[j-val]+val);
					}
					ni -= k;
					k *= 2;
				}
				int val = ni*vi;
				for(int j = C;j>=val;j--){
					f[j] = max(f[j],f[j-val]+val);
				}
			}
		
		}
		cout<<f[C]<<endl;	
		
	}
	return 0;
}

2.用f[c]=1表示价值c可达,用bool数组可节省大量空间~特别适用于vi=wi的题目。注意循环的顺序可适当降低时间复杂度
#include<iostream>
#include<cstring>
#define max(a,b) a>b?a:b
using namespace std;
bool f[100002];
int main(){
	int C,n,max_val;
	while(~scanf("%d%d",&C,&n)){
	
		if(!n){
			printf("0\n");
			continue;
		}	
		memset(f,0,sizeof(f));
		f[0] = 1;
		max_val = 0;    
		for(int i = 0;i<n;i++){
			int vi,ni;
			scanf("%d%d",&ni,&vi);
			if(!vi || !ni) continue;
			for(int j = C;j>=0;j--){
				if(!f[j]){
					continue;
				}
				for(int k = 1;k<=ni;k++){
					int vv = j+k*vi;
					if(vv > C || f[vv]){   //优化点:如果f[vv]已经为1,f[vv+k*vi]一定都已为1 
						break;
					}
					f[vv] = 1;
					max_val = max(max_val,vv);
				}
			}

		}
		cout<<max_val<<endl;	
		
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值