【PAT】1089. Insert or Merge (25)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort

1 2 3 8 4 5 7 9 0 6

题意:给出俩个数组,一个是初始数组origin,另一个是经过某种排序后的数组sorted。判断是采用了哪种排序的方法,并给出下一次排序后的结果。

分析:

(1)如果是插入排序,那么排序后的数组的前x个数字是递增的,后n-x个数字与原来的数组是相同的。

(2)如果判断出是合并排序,那么可以从初始数组开始,采用合并排序的方式对数组进行处理,每次处理后用vector自带的“==”功能来比较origin是否和sorted一样,如果一样了,则再进行一次合并排序,输出结果。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int N;

void show(vector<int> &vec){
	for(int i=0; i<vec.size(); i++){
		if(i==0){
			printf("%d",vec[i]);
		}else{
			printf(" %d",vec[i]);
		}
	}
	printf("\n");
}

int main(int argc, char** argv) {
	scanf("%d",&N);
	int i;
	vector<int> before(N), after(N);
	for(i=0; i<N; i++){
		scanf("%d",&before[i]);
	}
	
	for(i=0; i<N; i++){
		scanf("%d",&after[i]);
	}
	
	bool isInsert = true;
	for(i=1; i<N; i++){
		if(after[i] < after[i-1] ){
			break;
		}
	}
	int index = i;
	for(; i<N; i++){
		if(before[i] != after[i]){
			isInsert = false;
			break;
		}
	}
		
	if(isInsert){
		printf("Insertion Sort\n");
		sort(after.begin(), after.begin()+index+1);
		show(after);		
	}else{		
		int step=1, from=0, to;
		bool find = false;
		while(true){			 
			step *= 2;
			for(i=0; i*step<N; i++){
				from = i*step;
				to = ((from+step)<N)?(from+step):N;
				sort(before.begin()+from, before.begin()+to);
			}
			if(find){
				printf("Merge Sort\n");
				show(before);
				break;
			}
			if(before==after){
				find = true;
			}
		}			
	}	
	return 0;
}



  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值