PAT---A1035. Password (20)

题目要求:
To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line “There are N accounts and no account is modified” where N is the total number of accounts. However, if N is one, you must print “There is 1 account and no account is modified” instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
Sample Output 1:
2
Team000002 RLsp%dfa
Team000001 R@spodfa
Sample Input 2:
1
team110 abcdefg332
Sample Output 2:
There is 1 account and no account is modified
Sample Input 3:
2
team110 abcdefg222
team220 abcdefg333
Sample Output 3:
There are 2 accounts and no account is modified

解题思路:因为本题需要先打印不符合要求的字符串的个数,所以就没有办法边获取输入边判断,必须输入全部获取后并判断结束且将不符合要求的字符串个数统计完成后才开始打印。存在不符合要求的字符串则打印出name以及修正后的password,而全部符合要求则要根据输入的user的个数来判断打印内容。

参考代码:

#include <iostream>
#include <cstring>
using namespace std;
struct PAT{
    string name;
    char password[12] = {0};
};
int main()
{
    int N;
    int false1 = 0;        //有难分辨字符的密码的个数
    cin >> N;
    int true1[1000] = {0};      //标志位,为0则表明当前字符串无难分辨的字符
    struct PAT usr[1000];      //用来存储输入的字符串
    //依次获取输入并判断字符串中是否有难分辨的字符,有,则替换
    for(int i=0;i<N;i++)
    {
        cin >>usr[i].name;
        cin >>usr[i].password;
        //字符数组长度可以通过strlen来获取
        int k = strlen(usr[i].password);
        for(int j=0;j<k;j++)
            if(usr[i].password[j] == '1')
            {
                usr[i].password[j] = '@';
                true1[i] = 1;

            }
            else if(usr[i].password[j] == '0')
            {
                usr[i].password[j] = '%';
                true1[i] = 1;

            }
            else if(usr[i].password[j] == 'l')
            {
                usr[i].password[j] = 'L';
                true1[i] = 1;

            }
            else if(usr[i].password[j] == 'O')
            {
                usr[i].password[j] = 'o';
                true1[i] = 1;

            }
    }
    //统计有难分辨字符的字符串的个数
    for(int i=0;i<N;i++)
        if(true1[i]==1)
            false1++;
    //按要求打印
    if(false1!=0)
    {
         cout <<false1;
         for(int i=0;i<N;i++)
         {
             if(true1[i]!=0)
             {
                 cout <<endl<<usr[i].name<<" ";
                 cout <<usr[i].password;
             }
         }
    }
    else if((N-false1) == 1)
        cout<<"There is 1 account and no account is modified";
    else
        cout<<"There are "<<N<<" accounts and no account is modified";
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值