PAT---A1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

参考代码:

#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
    int max_size = 1001;              //因为由题目可知,Ni可以取到1000,所以这里的最大值设为1001。a[1001]的最后一项是a[1000]。
    double array_a[max_size] = {0};   //Y=array_a[X]表示的是指数为X的那一项的系数为Y


    int cin_a;             //输入的数的个数
    int a;                 //用来存储临时变量
    double b;             //用来存储临时变量
    int count_1 = 0;       //用来记录结果中不为0的项的个数
    cin >>cin_a;
    while(cin_a--)         //循环cin_a次
    {
        cin >>a>>b;
        array_a[a]= b;
    }
    cin >>cin_a;           //重新获取cin_a,这里也可以重新定义一个变量,但我们为了节约内存遂循环使用定义的变量
    while(cin_a--)         //同上一个函数一样
    {
        cin>>a>>b;
        array_a[a] += b;   //因为我们需要的是将指数相等的项相加,所以这里使用+=
    }
    for(int i=0;i<max_size;i++)  //此函数用于统计相同指数的项系数相加结果中不为0的项的个数
    {
        if(array_a[i]!=0)
            count_1++;
    }
    cout <<count_1;
    for(int i=max_size-1;i>=0;i--)            //从指数最大的项开始检测,若系数不为0则输出
        if(array_a[i]!=0)
            printf(" %d %.1f",i,array_a[i]);  //因为我们按照题目意思,应该将系数输出时保留一位小数,
                                             //但c++实现较为麻烦,所以我们此处使用c标准
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值