POJ 3311 Hie with the Pie

105 篇文章 0 订阅

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

East Central North America 2006

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

状压DP~

旅行商问题。

先floyd一遍求出来任意两点之间的最短距离dis[i][j],然后用f[i][j]表示目前的状态为i,处于j点的最小花费,其中i的二进制第k位表示点k+1的状态,为1则已经经过k+1,否则还没有经过。所以f[k][i]=min(f[k^(1<<(i-1))][j]+dis[j][i],f[k][i]),其中j为状态k下已经经过的点。

注意:

1.在记录的状态中,1<<i代表的是点i+1的状态。

2.在floyd中要算上起点0,但在DP中是不算的。


#include<cstdio>
#include<iostream>
using namespace std;
#define inf 999999999

int n,m,dis[11][11],f[2050][11],ans,tot;

int main()
{
	while(scanf("%d",&n)==1 && n)
	{
		for(int i=0;i<=n;i++)
		  for(int j=0;j<=n;j++) scanf("%d",&dis[i][j]);tot=(1<<n)-1;
		for(int k=0;k<=n;k++)
		  for(int i=0;i<=n;i++)
		    for(int j=0;j<=n;j++)
		      if(i!=k && j!=k && i!=j) dis[i][j]=min(dis[i][j],dis[i][k]+dis[k][j]);
		for(int k=1;k<=tot;k++)
		  for(int i=1;i<=n;i++)
		    if(k&(1<<(i-1)))
		    {
		    	if(k==(1<<(i-1))) f[k][i]=dis[0][i];
		    	else
		    	{
		    		f[k][i]=inf;
		    		for(int j=1;j<=n;j++)
		    		  if(k&(1<<(j-1)) && i!=j) f[k][i]=min(f[k][i],f[k^(1<<(i-1))][j]+dis[j][i]);
				}
			}
		ans=inf;
		for(int i=1;i<=n;i++) ans=min(ans,f[tot][i]+dis[i][0]);
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值