uva 10602 Editor Nottoobad

原题:

Company Macrohard has released it’s new version of editor Nottoobad, which can understand a few voice commands. Unfortunately, there are only two voice commands that it can understand — “repeat the last word”, “delete the last symbol”. However, when one uses “repeat the last word” the editor inserts a blank that separates the words. But the company claims that it is possible to type much faster — simply by less number of presses. For example, such a phrase like “this thin thing” requires only 6 presses of the keyboard.
Action Number of presses Content of the document
Press “this” 4 This
Say “repeat the last word” 0 this this
Say “delete the last symbol” 0 this thi
Press “n” 1 this thin
Say “repeat the last word” 0 this thin thin
Press “g” 1 this thin thing
In order to increase the popularity of its product the company decided to organize a contest where
the winner will be a person who types a given number of words with minimum number of presses.
Moreover, the first word must be typed first, and all the others can be typed in arbitrary order. So, if
words “‘apple”, “plum” and “apricote” must be typed, the word “apple” must be typed first, and
the words “plum” and “apricote” can be switched. And the most important for you — you are going
to take part in the contest and you have a good friend in the company, who told you the word which
will be used in the contest. You want be a winner J, so you have to write a program which finds the
order of the words, where the number of presses will be minimum.
Input
The first line of the input contains the T (1 ≤ T ≤ 15) the number of test cases. Then T test cases
follow. The first line of each test contains a number N (1 ≤ N ≤ 100) — the number of words that
must be pressed. Next N lines contain words — sequences of small Latin letters, not longer than 100
symbols. Remember that the first word must be pressed first!
Output
The first line of the output contains number X — the minimum number of presses, which one has to do
in order to type all the words using editor Nottoobad. Next N lines contain the words in that minimum
order.
If there are several solutions, you can output one of them.
Sample Input
3
3
this
thin
thing
4
popcorn
apple
apricote
plum
2
hello
hello
Sample Output
6
this
thin
thing
21
popcorn
plum
apricote
apple
5
hello
hello
原题有点凌乱,链接
https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1543
大意:
给你有个不完整的声控编辑器,只能执行如下指令:
1.重复上一个单词 2. 去掉最后一个字母
以上指令不需要按键
现在问你要打出给出的这些单词,最少按多少次按键。

#include <bits/stdc++.h>
using namespace std;

vector<string> vs;

int PreLen(const string &a, const string &b)
{
    int l = 0;
    while(l<a.size()&&l<b.size())
        if(a[l] == b[l])
            l++;
        else
            return l;
    return l;
}

int main()
{
    ios::sync_with_stdio(false);
    int t,n,ans;
    cin>>t;
    while(t--)
    {
        cin>>n;
        vs.clear();
        for(int i = 0 ;i < n ;i++)
        {
            string s;
            cin>>s;
            vs.push_back(s);
        }
        sort(vs.begin() , vs.end() );
        ans = vs[0].size();
        for(int i = 1; i < vs.size() ;i++)
        {
            int l = PreLen(vs[i-1] , vs[i]);
            ans += vs[i].size() - l;
        }
        cout<<ans<<endl;
        for(string s : vs)
            cout<<s<<endl;
    }
    return 0;
}



解答:
这题好简单,直接对字符串排序,也就是字典序排序,有相同前缀的字符就会出现在一起。然后用当前字符串长度减去相邻前缀的长度就是要按键的数量。

深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值