uva 10277 Boastin' Red Socks

原题:
You have a drawer that is full of two kinds of socks: red and black. You know that there are at least 2 socks, and not more than 50000. However, you do not know how many there actually are, nor do you know how many are red, or how many are black. (Your mother does the laundry!)
You have noticed, though, that when you reach into the drawer each morning and choose two socks to wear (in pitch darkness, so you cannot distinguish red from black), the probability that you pick two red socks is exactly p/q, where 0 < q and 0 ≤ p ≤ q. From this, can you determine how many socks of each colour are in your drawer? There may be multiple solutions — if so, pick the solution with the fewest total number of socks, but still allowing you to wear a couple of same color socks.
Input
Input consists of multiple problems, each on a separate line. Each problem consists of the integers p and q separated by a single space. Note that p and q will both fit into an unsigned long integer.
Input is terminated by a line consisting of two zeroes.
Output
For each problem, output a single line consisting of the number of red socks and the number of black
socks in your drawer, separated by one space. If there is no solution to the problem, print ‘impossible’.
Sample Input
1 2
6 8
12 2499550020
56 789
0 0
Sample Output
3 1
7 1
4 49992
impossible
大意:
给你两个数p/q表示在一堆红色和白色袜子中取出两只袜子为为红色袜子的概率,告诉你总袜子数不超过50000,现在问你红袜子和黑袜子有多少个?如果答案有多个,找出总数最小的那个。

#include <bits/stdc++.h>

using namespace std;
//fstream in,out;
long long q,p;
long long gcd(long long a,long long b)
{
    return b==0 ? a:gcd(b,a%b);
}
bool IsSqure(long long a)
{
    long long tmp=sqrt(a);
    return tmp*tmp==a;
}
int main()
{
    ios::sync_with_stdio(false);
    long long tot,red,tmp;
    while(cin>>p>>q,q+p)
    {
        if(p==0)
        {
            cout<<"0 2"<<endl;
            continue;
        }
        if(p==q)
        {
            cout<<"2 0"<<endl;
            continue;
        }
        long long g=gcd(p,q);
        q/=g;
        p/=g;
        bool flag=0;
        for(long long tot=2;tot<=50000;++tot)
        {

            if((tot*(tot-1))%q==0)
            {
                tmp=tot*(tot-1)/q;
                if(IsSqure(4*p*tmp+1))
                {
                    tmp=sqrt(4*p*tmp+1);
                    if((1+tmp)%2==0)
                    {
                        red=(1+tmp)/2;
                        cout<<red<<" "<<tot-red<<endl;
                        flag=1;
                        break;
                    }
                }
            }
        }
        if(!flag)
            cout<<"impossible"<<endl;
    }
    return 0;
}

解答:
这题应该不能算是数学题吧,首先枚举总数,然后根据方程判断能否整除和开根号之类的,如果都满足就输出结果就可以了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值