uva 10820 Send a Table

原题:
When participating in programming contests, you sometimes face the following problem: You know
how to calcutale the output for the given input values, but your algorithm is way too slow to ever
pass the time limit. However hard you try, you just can’t discover the proper break-off conditions that
would bring down the number of iterations to within acceptable limits.
Now if the range of input values is not too big, there is a way out of this. Let your PC rattle for half
an hour and produce a table of answers for all possible input values, encode this table into a program,
submit it to the judge, et voila: Accepted in 0.000 seconds! (Some would argue that this is cheating,
but remember: In love and programming contests everything is permitted).
Faced with this problem during one programming contest, Jimmy decided to apply such a ’technique’.
But however hard he tried, he wasn’t able to squeeze all his pre-calculated values into a program
small enough to pass the judge. The situation looked hopeless, until he discovered the following property
regarding the answers: the answers where calculated from two integers, but whenever the two
input values had a common factor, the answer could be easily derived from the answer for which the
input values were divided by that factor. To put it in other words:
Say Jimmy had to calculate a function Answer(x, y) where x and y are both integers in the range
[1, N]. When he knows Answer(x, y), he can easily derive Answer(k ∗ x, k ∗ y), where k is any integer
from it by applying some simple calculations involving Answer(x, y) and k.
For example if N = 4, he only needs to know the answers for 11 out of the 16 possible input value
combinations: Answer(1, 1), Answer(1, 2), Answer(2, 1), Answer(1, 3), Answer(2, 3), Answer(3, 2),
Answer(3, 1), Answer(1, 4), Answer(3, 4), Answer(4, 3) and Answer(4, 1). The other 5 can be derived
from them (Answer(2, 2), Answer(3, 3) and Answer(4, 4) from Answer(1, 1), Answer(2, 4) from
Answer(1, 2), and Answer(4, 2) from Answer(2, 1)). Note that the function Answer is not symmetric,
so Answer(3, 2) can not be derived from Answer(2, 3).
Now what we want you to do is: for any values of N from 1 upto and including 50000, give the
number of function Jimmy has to pre-calculate.
Input
The input file contains at most 600 lines of inputs. Each line contains an integer less than 50001 which
indicates the value of N. Input is terminated by a line which contains a zero. This line should not be
processed.
Output
For each line of input produce one line of output. This line contains an integer which indicates how
many values Jimmy has to pre-calculate for a certain value of N.
Sample Input
2
5
0
Sample Output
3
19
大意:
告诉你现在给你个函数f(x,y),让你打表。不过这个函数有一个性质,就是根据f(x,y)能算出f(kx,ky),k是任意整数,所以有了f(x,y)的话f(kx,ky)就不用存了。现在给你一个数n,问你需要存多少个数据,比如n=2的时候存3个(1,2)(1,1),(2,1)

#include<bits/stdc++.h>
using namespace std;

//fstream in,out;

int f[50001];
int phi[50001];
int main()
{
    ios::sync_with_stdio(false);
//  in.open("data.txt");
//  out.open("input.txt");
    for(int i=2;i<=50000;i++)
        phi[i]=0;
    phi[1]=1;
    f[1]=1;
    for(int i=2;i<=50000;i++)//euler
    {
        if(!phi[i])
            for(int j=i;j<=50000;j+=i)
            {
                if(!phi[j])
                    phi[j]=j;
                phi[j]=phi[j]/i*(i-1);
            }
    }
    for(int i=2;i<=50000;i++)
        f[i]=f[i-1]+phi[i]*2;
    int n;
    while(cin>>n,n)
    {
        cout<<f[n]<<endl;
    }
//  in.close();
//  out.close();
    return 0;
}

解答:
卡在一道别的题上,找了个简单的题目凑凑数。结果发现了这道题,哈哈= =.

题目有很强的递推性,所以先从f[n]和f[n-1]的关系入手。
画一个1到n的二维表格

(1,1) (1,2) (1,3)....  (1,n-1) (1,n)
(2,1)
.                               .
.                               .
.                               .
(n-1,1)
(n,1)..............            (n,n)
可以知道这个表是个对称的,观察第n列的(x,y),实际上就是(x,n),x从1到n。如果x和n不互质,那么一定又一个数k能使得Xk=x,Nk=n。所以就找1到n当中和n不互质的数目即可,也就是n的欧拉函数,在加上f[n-1]的计算结果就是答案。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值