poj 2991 Traveling by Stagecoach

题目:
Description

Once upon a time, there was a traveler.

He plans to travel using stagecoaches (horse wagons). His starting point and destination are fixed, but he cannot determine his route. Your job in this problem is to write a program which determines the route for him.

There are several cities in the country, and a road network connecting them. If there is a road between two cities, one can travel by a stagecoach from one of them to the other. A coach ticket is needed for a coach ride. The number of horses is specified in each of the tickets. Of course, with more horses, the coach runs faster.

At the starting point, the traveler has a number of coach tickets. By considering these tickets and the information on the road network, you should find the best possible route that takes him to the destination in the shortest time. The usage of coach tickets should be taken into account.

The following conditions are assumed.
A coach ride takes the traveler from one city to another directly connected by a road. In other words, on each arrival to a city, he must change the coach.
Only one ticket can be used for a coach ride between two cities directly connected by a road.
Each ticket can be used only once.
The time needed for a coach ride is the distance between two cities divided by the number of horses.
The time needed for the coach change should be ignored.

Input

The input consists of multiple datasets, each in the following format. The last dataset is followed by a line containing five zeros (separated by a space).

n m p a b
t1 t2 … tn
x1 y1 z1
x2 y2 z2

xp yp zp

Every input item in a dataset is a non-negative integer. If a line contains two or more input items, they are separated by a space.

n is the number of coach tickets. You can assume that the number of tickets is between 1 and 8. m is the number of cities in the network. You can assume that the number of cities is between 2 and 30. p is the number of roads between cities, which may be zero.

a is the city index of the starting city. b is the city index of the destination city. a is not equal to b. You can assume that all city indices in a dataset (including the above two) are between 1 and m.

The second line of a dataset gives the details of coach tickets. ti is the number of horses specified in the i-th coach ticket (1<=i<=n). You can assume that the number of horses is between 1 and 10.

The following p lines give the details of roads between cities. The i-th road connects two cities with city indices xi and yi, and has a distance zi (1<=i<=p). You can assume that the distance is between 1 and 100.

No two roads connect the same pair of cities. A road never connects a city with itself. Each road can be traveled in both directions.
Output

For each dataset in the input, one line should be output as specified below. An output line should not contain extra characters such as spaces.

If the traveler can reach the destination, the time needed for the best route (a route with the shortest time) should be printed. The answer should not have an error greater than 0.001. You may output any number of digits after the decimal point, provided that the above accuracy condition is satisfied.

If the traveler cannot reach the destination, the string “Impossible” should be printed. One cannot reach the destination either when there are no routes leading to the destination, or when the number of tickets is not sufficient. Note that the first letter of “Impossible” is in uppercase, while the other letters are in lowercase.
Sample Input

3 4 3 1 4
3 1 2
1 2 10
2 3 30
3 4 20
2 4 4 2 1
3 1
2 3 3
1 3 3
4 1 2
4 2 5
2 4 3 4 1
5 5
1 2 10
2 3 10
3 4 10
1 2 0 1 2
1
8 5 10 1 5
2 7 1 8 4 5 6 3
1 2 5
2 3 4
3 4 7
4 5 3
1 3 25
2 4 23
3 5 22
1 4 45
2 5 51
1 5 99
0 0 0 0 0
Sample Output

30.000
3.667
Impossible
Impossible
2.856
Hint

Since the number of digits after the decimal point is not specified, the above result is not the only solution. For example, the following result is also acceptable.

30.0

3.66667

Impossible

Impossible

2.85595
Source

Japan 2005 Domestic
中文:
(旅行家计划乘马车旅行。他所在国家有m个城市,城市间有若干道路相连。从某个城市沿着莫条道路到相邻的城市需要乘坐马车。而乘坐马车需要使用车票,每用一张车票只能通过一条路。每张车票上有马的数量,从一个城市到另外一个城市用时等于路长除以马匹数。现在这个旅行家有n张车票,第i张车票上的马匹数是ti。一张车票只能使用一次,换乘时间忽略。问从城市a到城市b所需时间最短是多少,如果不能到达输出Impossible。

//#include <bits/stdc++.h>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<iomanip>
using namespace std;
const int INF=9999999;
int n,m,p,a,b;
double t[11];
double d[31][31];
double dp[1025][31];
void solve()
{
    for(int i=0;i<(1<<n);i++)
        fill(dp[i],dp[i]+m,INF);
    dp[(1<<n)-1][a-1]=0;
    double res=INF;
//  for(int S=0;S<=(1<<n)-1;S++)
    for(int S=(1<<n)-1;S>=0;S--)
    {
        for(int v=0;v<m;v++)
        {
            for(int i=0;i<n;i++)
            {
                if(!(S>>i&1))
                {
                    for(int u=0;u<m;u++)
                    {
                        if(d[v][u]>=0)
                            dp[S][u]=min(dp[S][u],dp[S|(1<<i)][u]+d[v][u]/t[i]);
                        //  dp[S&~(1<<i)][u]=min(dp[S&~(1<<i)][u],dp[S][v]+(double)d[v][u]/t[i]);
                    }
                }
            }
        }
        res=min(res,dp[S][b-1]);
    }
    if(res==INF)
        cout<<"Impossible"<<endl;
    else
        cout<<fixed<<setprecision(3)<<res<<endl;
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>m>>p>>a>>b)
    {
        if(n+m+p+a+b==0)
            break;
        for(int i=0;i<n;i++)
            cin>>t[i];
        memset(d,-1,sizeof(d));
        for(int i=0;i<p;i++)
        {
            int x,y,z;
            cin>>x>>y>>z;
            d[x-1][y-1]=d[y-1][x-1]=z;
        }
        solve();
    }
    return 0;
}

解答:
挑战程序设计竞赛的第二版的状态压缩dp的例题,我想出来的是状态转移方程是
dp[S][u]=min(dp[S][u],dp[S|(1<< i)][v]+d[v][u]/t[i])
表示身上的表的状态为S到达城市u的最小时间(S当中没有马票i)可以由上一个有马票i的状态S|(1<< i)且在当前城市为v到达状态,通过坐马车走d[v][u]这条路转移过来。
可惜,我自己写的代码改了半天也没改对,参考书上代码,给写出来了.

深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值