【PAT】1067. Sort with Swap(0,*)


1067. Sort with Swap(0,*) (25)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10 3 5 7 2 6 4 9 0 8 1
Sample Output:
9
题意:每次只能用0与另一数字作交换,求若要完成从小到大的排序需要的最小交换次数

代码:

#include <stdio.h>

int findNotOK(int* arr,int begin,int end)	//从begin开始往后寻找未到位的数
{
	for(int i=begin;i<end;i++)
	{
		if(arr[i]!=i)return i;
	}
	return 0;
}

int main()
{
    int n;
	scanf("%d",&n);
	int* arr = new int[n];
	int i,t;
	
	for(i=0;i<n;i++)
	{
		scanf("%d",&t);
		arr[t]=i;
	}
	int tmp = 0;
	int count=0;
	int firstPos = 1;
	firstPos = findNotOK(arr,firstPos,n);

	while(firstPos)		//还有未到位的数字
	{
		if(arr[0]==0)		//如果0到位了,则与未到位的firstPos交换
		{
			arr[0] = arr[firstPos];
			arr[firstPos] = 0;
			count++;
		}

		while(arr[0]!=0)	//如果0不到位,则循环与自己所指向的值交换
		{
			tmp = arr[0];
			arr[0] = arr[tmp];
			arr[tmp] = tmp;
			count++;
		}
		firstPos = findNotOK(arr,firstPos,n);		//此时0归位了,找到下一个未到位的数字
	}
	printf("%d\n",count);

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值