POJ1118 HDU1432 Lining Up【水题】

509 篇文章 9 订阅
38 篇文章 3 订阅

Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 26016 Accepted: 8153

Description

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?


Your program has to be efficient!

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3

Source



问题链接POJ1118 HDU1432 Lining Up

题意简述输入n,输入n个整数对,即n个坐标点,问最多共线点数是多少。

问题分析:用暴力法解决这个问题,好在计算规模不算大。

程序说明:判断共线时,使用的是乘法,没有用除法,可以保证精确的计算结果。


AC的C语言程序如下:

/* POJ1118 HDU1432 Lining Up */

#include <stdio.h>

#define MAXN 700

struct {
    int x, y;
} p[MAXN];      /* point */

int main(void)
{
    int n, ans, max, i, j, k;

    while(scanf("%d", &n) != EOF && n != 0) {
        for(i=0; i<n; i++)
            scanf("%d%d", &p[i].x, &p[i].y);

        ans = 2;
        for(i=0; i<n; i++)
            for(j=i+1; j<n; j++) {
                max = 2;
                for(k=j+1; k<n; k++)
                    if ((p[j].x - p[i].x)*(p[k].y - p[j].y) == (p[j].y - p[i].y)*(p[k].x - p[j].x))
                        max++;
                if(max > ans)
                    ans = max;
            }

        printf("%d\n", ans);
    }

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值