POJ2348 UVa10368 HDU1525 Euclid's Game【博弈】

708 篇文章 19 订阅
509 篇文章 9 订阅

Euclid's Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4106    Accepted Submission(s): 1947


Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

 

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
 

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

 

Sample Input
 
 
34 1215 240 0
 
Sample Output
 
 
Stan winsOllie wins
 

Source


问题链接POJ2348 UVa10368 HDU1525 Euclid's Game


问题描述参见上文。

问题分析

  这是一个博弈问题。有以下几个要点:

  1.开始时,让a>b;

  2.若a和b有0,则先手胜;

  3.若a%b=0,则当前玩家胜;

  4.若a/b>1,则当前玩家可以胜(当前玩家知道<b,a%b>是否必胜,若不是则将<a,b>变为<a%b,b>即可)

  5.若b<a<2*b,则一步一步模拟下去。

程序说明:(略)

参考链接:(略)


AC的C++语言程序:

/* POJ2348 UVa10368 HDU1525 Euclid's Game */

#include <iostream>

using namespace std;

int main()
{
    int a, b;

    while(cin >> a >> b && (a || b)) {
        bool Stanwins = true;

        if(a < b)
            swap(a, b);
        while(b) {
            if(a % b == 0 || a / b > 1)
                break;
            a = a - b;
            swap(a, b);
            Stanwins = !Stanwins;
        }
        if(Stanwins)
            cout << "Stan wins" << endl;
        else
            cout << "Ollie wins" << endl;
    }

    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值