HDU2055 An easy problem【水题】

An easy problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28633    Accepted Submission(s): 18657


Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
 

Output
for each case, you should the result of y+f(x) on a line.
 

Sample Input
 
 
6R 1P 2G 3r 1p 2g 3
 

Sample Output
 
 
191810-17-14-4


问题链接HDU2055 An easy problem

问题简述:(略)

问题分析(略)

程序说明:输入格式有点特殊。使用条件表达式会是的程序代码变得比较简洁。

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* HDU2055 An easy problem */

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int n, a;
    char c;

    scanf("%d%*c", &n);
    while (n--) {
        scanf("%c%d%*c", &c, &a);

        printf("%d\n", a + (c < 'a' ? c - 'A' + 1 : 'a' - c - 1));
    }

    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值