HDU 2055 An easy problem

An easy problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21733    Accepted Submission(s): 14359


Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
 

Output
for each case, you should the result of y+f(x) on a line.
 

Sample Input
  
  
6 R 1 P 2 G 3 r 1 p 2 g 3
 

Sample Output
  
  
19 18 10 -17 -14 -4
 





#include <stdio.h>

int a[200];

int main(){
	int n,i = 1,j = -1,m;
	char ch = 'A',k = 'a';
	
	while(ch <= 'Z'){
		a[ch ++] = i ++;
		a[k ++] = j --;
	}
	
	scanf("%d",&n);
	
	while(n --){
		getchar();
		scanf("%c%d",&ch,&m);

		printf("%d\n",a[ch] + m);
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值