UVA10921 Find the Telephone【编码】

In some places is common to remember a phone number associating its digits to letters. In this way the expression “MY LOVE” means 69 5683. Of course there are some problems, because some phone numbers can not form a word or a phrase and the digits 1 and 0 are not associated to any letter.

  Your task is to read an expression and find the corresponding phone number based on the table below. An expression is composed by the capital letters (A-Z), hyphens (-) and the numbers 1 and 0.

Input

The input consists of a set of expressions. Each expression is in a line by itself and has C characters, where 1 ≤ C ≤ 30. The input is terminated by enf of file (EOF).

Output

For each expression you should print the corresponding phone number.

Sample Input

1-HOME-SWEET-HOME

MY-MISERABLE-JOB

Sample Output

1-4663-79338-4663

69-647372253-562

 

 

问题链接UVA10921 Find the Telephone

问题简述:(略)

问题分析

  水题,字母转数字,做个表查一下就好了。

程序说明:(略)

题记:(略)

参考链接:(略)

 

AC的C++语言程序如下:

 

/* UVA10921 Find the Telephone */

#include <iostream>
#include <string>
#include <ctype.h>

using namespace std;

char num[] = "22233344455566677778889999";

int main()
{
    string s;

    while(cin >> s) {
        for(int i = 0; s[i]; i++)
            if(isupper(s[i]))
                cout << num[s[i] - 'A'];
            else
                cout << s[i];
        cout << endl;
    }

    return 0;
}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值